UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
1,035 Views
Registered: ‎01-30-2018

DNNDK 2.08 Beta in ZCU104 has ERRORS

Hello all,

I'm testing DNNDK 2.08 Beta in ZCU104 and I'm encountering some errors.

The first one is about the install.sh script.

You have to make this modification in order to make this script run.

#my_board_type="zcu104"
my_board_type="xlnx"

 

After this, I try to run: root@xlnx:~/deephi_dnndk_v2.08_beta/ZCU104/samples/video_analysis# ./video_analysis video/structure.mp4
And the video gets frozen after a few seconds and I'm forced to restart the FPGA because the whole system gets frozen.

 

How can I solve this issue? I don't experience this errors in the previous version (2.07 Beta).

 

Thanks in advance.

 

0 Kudos
6 Replies
Visitor lee_toun
Visitor
996 Views
Registered: ‎01-10-2019

Re: DNNDK 2.08 Beta in ZCU104 has ERRORS

I encounter this situation too when I run the samples face_detection & pose_detection。 does anyone has advice?

0 Kudos
Visitor lixun123
Visitor
957 Views
Registered: ‎09-29-2018

Re: DNNDK 2.08 Beta in ZCU104 has ERRORS

I have also encountered this problem, but there is no such problem in ZCU102.

0 Kudos
Explorer
Explorer
866 Views
Registered: ‎10-24-2008

Re: DNNDK 2.08 Beta in ZCU104 has ERRORS

@lixun123@kardec@lee_tounIdeally I would like to test this myself, but I do not have a 104 board here.  Is it possible for one of you fine folks to confirm if you still see issues in the the new public release version?

https://www.xilinx.com/products/design-tools/ai-inference/ai-developer-hub.html#edge

--Quenton

0 Kudos
Contributor
Contributor
832 Views
Registered: ‎09-19-2018

Re: DNNDK 2.08 Beta in ZCU104 has ERRORS

I'm trying the last release with the last image, and the problems are still there ...

0 Kudos
Xilinx Employee
Xilinx Employee
740 Views
Registered: ‎02-18-2013

Re: DNNDK 2.08 Beta in ZCU104 has ERRORS

Maybe your ZCU104 board has power issue in running the DNN in full speed. 

As a workaround, attachments are irps5401.ko and irps5401.sh. You need to manually execute irps5401.sh every time you power up the evaluation boards. If there is no power off, but just reboot, you don't have to execute irps5401.sh again.

Alternatively, you can put the installation of irps5401.ko into the boot script, and then you can always use it later.

0 Kudos
Contributor
Contributor
434 Views
Registered: ‎09-19-2018

Re: DNNDK 2.08 Beta in ZCU104 has ERRORS

"Alternatively, you can put the installation of irps5401.ko into the boot script, and then you can always use it later."

Dear @aluo ,

Can you please explain the procedure to put the installation of irps5401.ko into the boot script ?

Thanks in advance.

0 Kudos