cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Explorer
Explorer
11,384 Views
Registered: ‎04-07-2013

7 series DDR3 MIG simulation, how to speed up?

Jump to solution

Hello everybody:

 

 

I use Modelsim SE to simulate 7 series MIG core generated by ISE 14.6 coregen.

The parameter setting is as follow:

 

parameter SIM_BYPASS_INIT_CAL = "FAST";
// # = "SIM_INIT_CAL_FULL" - Complete
// memory init &
// calibration sequence
// # = "SKIP" - Not supported
// # = "FAST" - Complete memory init & use
// abbreviated calib sequence

 

I run under "FAST" mode, but it still takes 8 minutes for calibration to be done, and I tried "SKIP" but errors happened and simulation stopped.

 

I tried setting ps as simulation resolution instead of fs and comment out  "log -r /*" in sim.do file, but it seems no change on simulation time.

 

Could anyone help me with this? Thanks!

 

 

 

0 Kudos
Reply
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
18,461 Views
Registered: ‎07-11-2011

Hi,

 

Yes, Slow simulation is main draw back in MIG 7 series IP, but based on the feed bcak the simulation time is greatly improved for Ultrascale.

Unfortunately you have to bear with the slowness , FAST is the only option.

---------------------------------------------------------------------------------------------
Please do google search before posting, you may find relavant information.
Mark the post - "Accept as solution" and give kudos if information provided is helpful and reply oriented

View solution in original post

0 Kudos
Reply
7 Replies
Xilinx Employee
Xilinx Employee
11,374 Views
Registered: ‎07-11-2011

Hi,

MIG 7 series do not support SKIp option for simulation , you can check this in UG586 as well

You should see calib_done asserted around 50us of simulation time real time depends on many factors like machine RAM, Simulator used.

 

Also you are not supposed to change the simulation resolution time other than the one given in sim_tb_top, if you did calibration may not complete and possibility to see errors

---------------------------------------------------------------------------------------------
Please do google search before posting, you may find relavant information.
Mark the post - "Accept as solution" and give kudos if information provided is helpful and reply oriented
0 Kudos
Reply
Xilinx Employee
Xilinx Employee
11,368 Views
Registered: ‎07-11-2011

Hi,

 

If your version of MIG UG shows SKIP is suported then it is incorrect

Please refe below link which applis to DDR2 and 3 as well.

http://www.xilinx.com/support/answers/57437.html

 

To speed up simulation only FAST is the option.

Other factors like memory width can effect the simulation time.

Please use Questasim for better results

---------------------------------------------------------------------------------------------
Please do google search before posting, you may find relavant information.
Mark the post - "Accept as solution" and give kudos if information provided is helpful and reply oriented
0 Kudos
Reply
Moderator
Moderator
11,358 Views
Registered: ‎04-17-2011
Moving to MIG board.
Regards,
Debraj
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Reply
Explorer
Explorer
11,337 Views
Registered: ‎04-07-2013
Yes, what I could choose is only "FAST" in my MIG simulation.
I installed Questasim but it is not any faster than modelsim.
0 Kudos
Reply
Xilinx Employee
Xilinx Employee
18,462 Views
Registered: ‎07-11-2011

Hi,

 

Yes, Slow simulation is main draw back in MIG 7 series IP, but based on the feed bcak the simulation time is greatly improved for Ultrascale.

Unfortunately you have to bear with the slowness , FAST is the only option.

---------------------------------------------------------------------------------------------
Please do google search before posting, you may find relavant information.
Mark the post - "Accept as solution" and give kudos if information provided is helpful and reply oriented

View solution in original post

0 Kudos
Reply
Explorer
Explorer
11,330 Views
Registered: ‎04-07-2013
I use optimization option in vsim command: -voptargs="+acc+sim_tb_top", then I get three times faster.
0 Kudos
Reply
Explorer
Explorer
11,329 Views
Registered: ‎04-07-2013
By the way, I test Modelsim 10.1a, 10.2c, and QuestaSim 10.2c, it seems like QuestaSim is not faster than the other two.
0 Kudos
Reply