cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
zhengchaofeng
Observer
Observer
1,177 Views
Registered: ‎02-01-2018

DDR4 DQS Gate Fail on KCU1500 board

Jump to solution

Hello Guys 

  I modified the code of KCU1500 project to add custom functions in vivado version 2017.4. But It got "Calibration Failed" problem. 

The error message is as following:

1-DQS Gate Fail

Pattern not found on GT_STATUS, all samples were 1. Expecting to sample the preamble. Error found on Rank 0, Byte 0, Nibble 1.

 My implement of DDR4 MIG is as following and connected S_AXI_0 with Microblaze, S_AXI_1 with xdma.

无标题.png

 

According to AR# 65054, I changed the CAS Latency to 16 and 18, but it failed with same problem.

 

0 Kudos
1 Solution

Accepted Solutions
coryb
Moderator
Moderator
1,123 Views
Registered: ‎02-11-2014

Hello @zhengchaofeng,

It sounds like your pinout might be wrong for the KCU1500. You should be able to use the DDR4 Board Preset for the KCU1500 to reassure the pinout is correct. There is also a dedicated clocking resource for each DDR4 controller that can be accessed with board presets.

Thanks,
Cory

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

1 Reply
coryb
Moderator
Moderator
1,124 Views
Registered: ‎02-11-2014

Hello @zhengchaofeng,

It sounds like your pinout might be wrong for the KCU1500. You should be able to use the DDR4 Board Preset for the KCU1500 to reassure the pinout is correct. There is also a dedicated clocking resource for each DDR4 controller that can be accessed with board presets.

Thanks,
Cory

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post