cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
erf
Visitor
Visitor
182 Views
Registered: ‎08-28-2019

[Xicom 50-38] xicom: The current version of Vivado does not support this detected version of the MIG core. 2015.2 is the last version supporting it.

I get this 'CRITICAL WARNING' when I use the hardware manager to 'Open Target' on my design. The design was created on Vivado 2019.1  It uses a 'DDR4 SDRAM (MIG) (2.2)'. It is targeted for the KCU105 board. The build has no errors or critical warnings. After seeing this warning, I started a new design and only added a Microblaze and MIG. I get the same warning.

The message indicates that the MIG core that's used is not supported for versions of Vivado after 2015.2. How is it I'm able to instantiate the MIG from the 'board' tab in 'IP Integrator' or, for the second case from the 'IP Catalog' in Vivado 2019.1 and get an IP that's not supported in that tool. The oldest version of Vivado I've ever used is '2018.3'.

The 'Hardware' tab of 'Program and Debug' shows a status of 'Not Supported' next to 'MIG_1 (MIG)' I have no idea where the name 'MIG_1' comes from. My IP Integrator diagram shows the instance as DDR4_0.

Is this a tool issue or am I doing something wrong.

0 Kudos
0 Replies