UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

XAUI TX Losing Lock

Adventurer
Posts: 85
Registered: ‎08-26-2013

XAUI TX Losing Lock

[ Edited ]

Hi

I'm using XAUI in my design connected to a free run LVDS clock in MGTREFCLK pins that scoping shows true dynamic in my custom board. XAUI Lock fail is my problem. Loosing lock with 156.25 MHz clock on kintex7 fpga with vivado tool is main problem but my code has been tested by xilinx platform and the results were perfect. Constraining clock part in my .xdc file consists of LOC records and period constraint and GTX constraints is copied from example design xdc file. When i remove lock asynchronous condition for starting generation and send procedure, every thing is ok by transceiver and other parts of my code. Can any one help me by providing some probably reasons?

 

Regards

Xilinx Employee
Posts: 3,313
Registered: ‎02-06-2013

Re: XAUI TX Losing Lock

Hi

 

Check if your reference clock meets the jitter specification required from below AR

 

https://www.xilinx.com/support/answers/44549.html

 

Check if the resets are fine and the free running clock to the core is stable before de-asserting the resets.

Regards,

Satish

--------------------------------------------------​--------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful.
--------------------------------------------------​-------------------------------------------