cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
SimratSandhu
Visitor
Visitor
476 Views
Registered: ‎12-03-2020

AMP for 2 a53 core applications running on bare metal in Zynq MPSOC

I am trying to run the AMP configuration for two a53 cores on Zynq MPSOC running on bare metal application driver.

The AMP framework is available with Linux OS for MPSOC or it's available on bare metal for Zynq 7000 series.  

Is there any way that I can work around and modify the FSBL files for MPSOC for bare metal application? Though I tried changing the destination load address, partition index and pointing the partition pointer to CPU1 but it doesn't work that way. I guess I am missing out on something. 

I am using ZCU102 Ultrascale board.

Any lead would be appreciated. 

Thanks!

0 Kudos
2 Replies
jovitac
Moderator
Moderator
436 Views
Registered: ‎05-10-2017

I'm not sure what you are trying to do. AMP is supported between A53 and R5 (in ZynqMP) or A9-0 and A9-1 (in Zynq7000). We don't have AMP support between A53-0 and A53-1

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
SimratSandhu
Visitor
Visitor
410 Views
Registered: ‎12-03-2020

Okay.. I guess AMP is probably not the correct term to use here. 

I am trying to run one application on a53-0 and another on a53-1. Is there a way this is possible on Zynq MPSoC ? 

Thanks!

0 Kudos