UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor frankxank
Visitor
943 Views
Registered: ‎04-18-2018

Remote processor will not run

Jump to solution

Hi,

 

I have gotten the echo-test OpenAmp demo to run successfully on our custom board. I have now pulled all the code needed to get remoteproc and rpmsg running from the demo and integrated it into Petalinux, the Linux app, and the standalone app. The output I get indicates that the standalone starts running, but then the kernel crashes. The crash dumps indicate the kernel stops in completely different places each time, indicating runtime memory corruption. I have attached a file showing these errors for 2 runs.

 

All our tools are v2017.3.

 

After reading other posts on this forum, I suspect the cause is my linker script. I have edited it to be as similar as possible to the one given for the echo-test standalone, and I have attached it below. I have also attached my openamp device-tree. Could you please take a look at it and see if you see any problems?

 

One thing I've wondered about is that elf_ddr_0 and rproc_0_reserved overlap, but that is how they are set up in the echo-test demo.

 

Thanks for any help you can give!

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
1,264 Views
Registered: ‎05-10-2017

Re: Remote processor will not run

Jump to solution

To have -DUSE_AMP=1 in your bsp settings. You will need this to disable initialization of shared resources

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
2 Replies
Moderator
Moderator
1,265 Views
Registered: ‎05-10-2017

Re: Remote processor will not run

Jump to solution

To have -DUSE_AMP=1 in your bsp settings. You will need this to disable initialization of shared resources

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Visitor frankxank
Visitor
834 Views
Registered: ‎04-18-2018

Re: Remote processor will not run

Jump to solution
You were right. I had a typo in that option.
0 Kudos