UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer kvkhekale
Observer
721 Views
Registered: ‎11-17-2018

"Failed to open rpmsg0 file /dev/rpmsg0" on petalinux 2017.4 openamp

Hello all,

We are trying to run Openamp project on petalinux 2017.4 on picozed board. 

As shown in the logs, demo application image_echo_test boots  and remoteproc0 also starts. 

But, as we give command of echo_test start, we are getting error message as "Failed to open rpmsg file /dev/rpmsg0."

 

the device tree settings for system-user.dtsi are done according to the settings UG1is mail. 186. 

 

Please guide regarding this matter.

I have attached error logs with this mail

0 Kudos
2 Replies
Moderator
Moderator
640 Views
Registered: ‎05-10-2017

Re: "Failed to open rpmsg0 file /dev/rpmsg0" on petalinux 2017.4 openamp

I don't see any error logs or device-tree attached. Please attach both.

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Observer kvkhekale
Observer
295 Views
Registered: ‎11-17-2018

Re: "Failed to open rpmsg0 file /dev/rpmsg0" on petalinux 2017.4 openamp

I have attached error logs as an attachment.

Attaching the device tree as follows:

Please let me know if you need any more information regarding this 

 

 

 

0 Kudos