cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
481 Views
Registered: ‎02-05-2014

Bank13 of XC7Z020 are not sampling the Input Signal at more than 140 Mhz with MYIR Z-Turn -2 Speed grade Boad

Dear All,

      Actually we are using MYIR Zturn board for some image sensor interface applications .The sensor Data output frequency range can go till 240 Mhz .So,until 140 Mhz we can able to receive the Clk signal from Image sensor in all Banks(13,34,35) properly but Once it is reached more than 140 Mhz, Bank 13 is getting RC Effect and we cannot able to get "Vil "  level properly so we are missing the data from Sensor to Zynq PL I/O's .Meanwhile ,other banks are sampling the sensor data properly without any issue .My question is what is the restriction with Bank 13 of Zynq SOC over remaining two Banks .Is there any kind of constraints required to match the lower threshold level .Please anyone can support with this issue.Thanks 

 

Tags (1)
0 Kudos
8 Replies
Highlighted
Moderator
Moderator
431 Views
Registered: ‎04-18-2011

Which IO standard is this?

Can you share scope shots of this clock you are having  an issue with?

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Adventurer
Adventurer
369 Views
Registered: ‎02-05-2014

Dear Klumsade ,

 

        Thank you very much for your reply .

        We are using HSTL_I_18 .After Sensor Interface we cannot see the offset difference but we are facing Noise issue with those Bank 13 I/O's .Please let me know the reason for this .? We need to do any specific settings in those I/O pins .

 

0 Kudos
Highlighted
Adventurer
Adventurer
365 Views
Registered: ‎02-05-2014

 
thumbnail_image.png
0 Kudos
Highlighted
Moderator
Moderator
332 Views
Registered: ‎04-18-2011

It looks to me as though you are using the split termination. 

This should have the effect of matching the load to the trace impedance. So the signal should be clean (the split termination will have the effect of biasing the signal around VCCO/2, so you will not see the signal swing all the way to vcco and ground but the edges should be clean and free of reflections. 

I would still like to see a scope shot of this, we can't understand what you mean by a noise issue without seeing it... 

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Advisor
Advisor
321 Views
Registered: ‎04-26-2015

I could be wrong, but aren't all the Z-Turn's I/O banks powered from 3.3V?

Highlighted
Adventurer
Adventurer
216 Views
Registered: ‎02-05-2014

@klumsde  

Thanks a lot for your reply...

After we added the untuned_split_50 ohm for all the I/P pins  we are getting good  Signal but our doubt is, If there is any issue with power consumption if 50 such inputs are defined with untuned_split_50 ohm setting which means at 1.8v, each one will take about 25mA current and 50 such will consume more than 1A current just for IO purpose?

Please help us to solve this issue

 

0 Kudos
Highlighted
Moderator
Moderator
148 Views
Registered: ‎04-18-2011

untuned split is implemented as a 2*Z0 to vcco and 2*Z0 to ground. 

 

so untuned split 50 is using 100ohms to vcco and ground. 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Tags (1)
0 Kudos
Highlighted
Adventurer
Adventurer
105 Views
Registered: ‎02-05-2014

Dear @klumsde 

      Thanks for your reply .You gave nice information to move ahead but still we have some issue in result .

I will post the outcome in case we will find the issue.

 

0 Kudos