UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
6,002 Views
Registered: ‎04-14-2016

7 Series GTH Reset after line rate change

Jump to solution

Hello,

I want to know when do I have to perform a reset after changing:

1.) QPLL/CPLL settings

2.) TXRATE/RXRATE through DRP

I know that ug476 says how to perform the reset for 1.) and for 2.), I know that it is NOT performed automatically according to this forum (even in ug476 stands something different). What I'm thinking about is, that I perform all changes through DRP and then use the given TX/RX reset FSMs to perform the reset sequence. The problem is, that afterwards the transceivers stop operation. I can only see this behaviour on the FPGA, not in the simulations (post implementation simulation). I use a 10GBits design as base and switch then to 4GBits or 8GBits.

I have no warnings/errors/critical warnings which I can connect to this problem. Only some warning about CONFIG_VOLTAGE (not set for my design), where can I set this and is this required?

My settings:

Line rate 

8Gbits 

10Gbits 

13.1Gbits 

6Gbits 

4Gbits 

Reference clock 

200MHz 

200MHz 

204.688MHz 

120MHz 

200MHz 

QPLL_FBDIV 

b0010000000 (=40) 

b0101110000 (=100) 

b0011100000(=64) 

b0101110000 (=100) 

b0010000000 (=40) 

QPLL_REFCLOCK_DIV : integer 

1 

2 

1 

1 

1 

RXOUT_DIV/TXOUT_DIV : integer 

(0x0088) 

1 

1 

1 

2 

2 

QPLL_FBDIV_RATIO : binär 

(=0 wenn QPLL_FBDIV=66) 

1 

1 

1 

1 

1 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Adventurer
Adventurer
11,606 Views
Registered: ‎04-14-2016

Re: 7 Series GTH Reset after line rate change

Jump to solution

Ok, I found the problem and fixed it. Thank you for your help. But for the virtex-7 ht there is only one possible CONFIG_VOLTAGE, why do I have to specifiy this manuel (if I select the wrong, I get an error which tells me there is only ONE choice: 1,8V). But thanks for the AR link, this removed my last warning in the implementation section.

0 Kudos
3 Replies
Moderator
Moderator
5,998 Views
Registered: ‎02-16-2010

Re: 7 Series GTH Reset after line rate change

Jump to solution
Check AR#55660
http://www.xilinx.com/support/answers/55660.html
------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
Adventurer
Adventurer
5,991 Views
Registered: ‎04-14-2016

Re: 7 Series GTH Reset after line rate change

Jump to solution

Thank you, but sadly this does't solved my problem. I think QPLL is again not locking. Should I upload my design if this helps?

0 Kudos
Highlighted
Adventurer
Adventurer
11,607 Views
Registered: ‎04-14-2016

Re: 7 Series GTH Reset after line rate change

Jump to solution

Ok, I found the problem and fixed it. Thank you for your help. But for the virtex-7 ht there is only one possible CONFIG_VOLTAGE, why do I have to specifiy this manuel (if I select the wrong, I get an error which tells me there is only ONE choice: 1,8V). But thanks for the AR link, this removed my last warning in the implementation section.

0 Kudos