UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor danielsulik
Visitor
4,469 Views
Registered: ‎09-05-2012

ERROR:Place:1073 - Placer was unable to create RPM[GTXE_CHANNEL_RPMs] for the component

Hi,

I am targetting VC707 SFP+ interface and having difficulties to build the design when using my ucf setting.

Using ISE14.2.

I created  ten_gig_eth_pcs_pma_v2_1 from coregen and wired up my application to the examle generated by coregen.

PCS/PMA + GTX

My ucf is as follows:

CONFIG PART = xc7vx485t-ffg1761-2;
NET REFCLK_P LOC = AK34 | IOSTANDARD=LVCMOS18; # Bank 14 VCCO - VCC1V8_FPGA - IO_L12P_T1_MRCC_14
NET REFCLK_N LOC = AL34 | IOSTANDARD=LVCMOS18; # Bank 14 VCCO - VCC1V8_FPGA - IO_L12N_T1_MRCC_14

NET RESET LOC = AV39 | IOSTANDARD=LVCMOS18; # Bank 15 VCCO - VCC1V8_FPGA - IO_L11N_T1_SRCC_15

NET RX_N  LOC = AL5 | IOSTANDARD=LVCMOS18;
NET RX_P  LOC = AL6 | IOSTANDARD=LVCMOS18;
NET TX_N  LOC = AN1 | IOSTANDARD=LVCMOS18;
NET TX_P  LOC = AN2 | IOSTANDARD=LVCMOS18;

In map stage I get the follwing error.

ERROR:Place:1073 - Placer was unable to create RPM[GTXE_CHANNEL_RPMs] for the
   component
   i_ten_gig_eth_pcs_pma_v2_1_example_design/ten_gig_eth_pcs_pma_block/gtwizard_
   10gbaser_i/gt0_gtwizard_10gbaser_gt_i/gtxe2_i of type GTXE_CHANNEL for the
   following reason.
   The reason for this issue:
   All of the logic associated with this structure is locked and the relative
   placement of the logic violates the structure. The problem was found between
   the relative placement of GTXE_CHANNEL
   i_ten_gig_eth_pcs_pma_v2_1_example_design/ten_gig_eth_pcs_pma_block/gtwizard_
   10gbaser_i/gt0_gtwizard_10gbaser_gt_i/gtxe2_i at site GTXE2_CHANNEL_X1Y2 and
   OPAD tx_n at site OPAD_X1Y2.  The following components are part of this
   structure:
      GTXE_CHANNEL  
   i_ten_gig_eth_pcs_pma_v2_1_example_design/ten_gig_eth_pcs_pma_block/gtwizard_
   10gbaser_i/gt0_gtwizard_10gbaser_gt_i/gtxe2_i
      OPAD   tx_n

I recon the problem is GTX location. Is coregen generated example tied up to a specific GTX location?

How to change it if so.

Regards

Dan

0 Kudos
1 Reply
Visitor danielsulik
Visitor
4,425 Views
Registered: ‎09-05-2012

Re: ERROR:Place:1073 - Placer was unable to create RPM[GTXE_CHANNEL_RPMs] for the component

Problem, solved.

Documentation (ug885_VC707_Eval_bd.pdf, page 36) specs wrong pins for GTX module.

 

Correct pins are

AL5 = SFP_RX_N,

AL6 = SFP_RX_P,

AM3 = SFP_TX_N,

AM4 = SFP_TX_P

 

 

0 Kudos