UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
14,914 Views
Registered: ‎03-31-2016

[Labtools 27-3165] End of startup status: LOW

I get the following error when i try to program the Artix-7 FPGA through the JTAG port using Platform Cable USB II on my board.  I try the same thing on a different board and it works without any issues.  What could be causing this error?  I have looked at all signals and voltages around the FPGA and all are identical between the two boards.  

 

I looked at another post with similar error message and it did not help.  I NEED HELP.......

 

set_property PROBES.FILE {} [lindex [get_hw_devices] 0]
set_property PROGRAM.FILE {C:/_Projects-FPGA/FTU100a2/FTU100a2.runs/impl_2/FTU100a2.bit} [lindex [get_hw_devices] 0]
program_hw_devices [lindex [get_hw_devices] 0]
ERROR: [Labtools 27-3165] End of startup status: LOW
program_hw_devices: Time (s): cpu = 00:00:06 ; elapsed = 00:00:06 . Memory (MB): peak = 1713.832 ; gain = 0.000
ERROR: [Common 17-39] 'program_hw_devices' failed due to earlier errors.

19 Replies
Xilinx Employee
Xilinx Employee
14,904 Views
Registered: ‎04-16-2012

Re: [Labtools 27-3165] End of startup status: LOW

Hi jn.shah55@gmail.com

 

Did you try reducing the cable speed?

Are you using the same bit file for programming in other boards?

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
14,901 Views
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hello Vinay, yes & yes.  What else should i look for?

0 Kudos
14,896 Views
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hello Vinay, wrong answer from me.  How do i reduce the cable speed from the Hardware Manager in Vivado 2016.1?  If i remember it correctly, that option was available in Impact, but i don't see that in Hardware Manager.

0 Kudos
Xilinx Employee
Xilinx Employee
14,891 Views
Registered: ‎04-16-2012

Re: [Labtools 27-3165] End of startup status: LOW

Hi jn.shah55@gmail.com

 

Follow below steps to reduce the cable speed:

 

1. Open HW Manager in Vivado GUI

2. Click on Open Target and select Open New Target

3. Click Next twice

4. In the "Hardware Targets" window, you will find the JTAG Clock Frequency.

5. Click on the drop-down and select the frequency.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
14,890 Views
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hello Vinay, it works without any issues with exactly the same setup and same .BIT file, if i change out my current board with an exactly similar board.  Only difference is that on the good board I get the "INFO: [Labtools 27-3164] End of startup status: HIGH" message instead of "ERROR: [Labtools 27-3165] End of startup status: LOW" message......

0 Kudos
14,889 Views
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Tried out all clock speed options.  No change.  Still get the same error on End of Startup Status: LOW

0 Kudos
14,865 Views
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hi Vinay, any suggestions?

0 Kudos
Xilinx Employee
Xilinx Employee
14,863 Views
Registered: ‎04-16-2012

Re: [Labtools 27-3165] End of startup status: LOW

Hi jn.shah55@gmail.com

 

Share the status registers after programming failure.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
14,831 Views
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hi Vinay, can you please tell me the steps to read back the status register after the failure?

0 Kudos
11,813 Views
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hi Vinay, see attached file for all the status registers info after the most recent programming failure.  Please let me know if you see anything that I am missing.

 

Thanks,

Jay Shah

0 Kudos
11,802 Views
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hi Vinay, did you get a chance to look at the status register details?  

0 Kudos
Xilinx Employee
Xilinx Employee
11,794 Views
Registered: ‎02-14-2014

Re: [Labtools 27-3165] End of startup status: LOW

Hello jn.shah55@gmail.com,

 

Few other pointers to narrow down the issue further -

 

1. Do you observe this issue even if you try to configure this device with any other bitstream ?

2. Can you check if your design has any critical warnings / warnings related to this error ?

3. Is it possible to assign PACKAGE_PIN and IOSTANDARD constraints to each IO port and check if it solves the issue ?

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
11,772 Views
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hello Ashish, answers to your questions:

(1) same result when used with other .BIT file

(2) I need to check warnings.  I will report in next message

(3) I do have PACKAGE_PIN and IOSTANDARD assigned to each IO port.  See attached XDC

 

Thanks,

Jay Shah

0 Kudos
Adventurer
Adventurer
11,334 Views
Registered: ‎08-04-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hello jn.shah55@gmail.com

 

Were you able to find a solution to the problem?

I get the same problem in Ubuntu 14.04, whereas the cable is not even detected in Windows 10.

Please let me know if you find the solution,

 

Regards,

Rajat Rao

0 Kudos
11,313 Views
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hello Rajat, my problem was the signal integrity on JTAG interface connections to the FPGA (Artix-7).  Specifically, the clock (TCK) signal.  See attached JPG images for the proper JTAG termination.  Once I did this, I do not have a problem anymore.  Since my board is already laid out and fabricated, I did not implement the buffering also recommended for the JTAG interface.

 

I also had improper termination on the 4-bit data bus between the flash PROM and the FPGA.  I am using the flash in SPIx4 mode.  I corrected the interface by changing the series resistors to 100 ohms on the data bus.

 

Hope this helps.

 

Jay Shah

JTAG Termination Buffers.JPG
JTAG Termination.JPG
0 Kudos
Voyager
Voyager
5,350 Views
Registered: ‎10-12-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hi jn.shah55@gmail.com@rajatrao @ashishd @vuppala

 

I am getting same issue, can you please let me know the exact reason ?

 

I am using xc7k410tffg676-2c part for customboard and JTAG_SMT2 for FPGA programming interface. FPGA part detected but not programmed . 

 

Any help or suggestions are highly appreciated. 

 

Thank you 

S Sampath 

Newbie nikithsai
Newbie
4,519 Views
Registered: ‎07-12-2018

Re: [Labtools 27-3165] End of startup status: LOW

Hello jn.shah55@gmail.com

 

I also got the same error. But I had solved it by reconnecting the whole device by rebooting my PC and re-powering the ZED Board.

0 Kudos
936 Views
Registered: ‎02-04-2019

Re: [Labtools 27-3165] End of startup status: LOW

I am using Vivado 2018.3, trying to programme an Artix XC7A50T on a custom board via an interface board using the HW Manager and the Platform Cable USB II  . I can see the chain (comprising of the FPGA and an PIC). When I attempt to programme the FPGA only, with my .bit file I get the

ERROR: [Labtools 27-3165] End of startup status: LOW

error. I have tried lowering the jtag clock speed.  We are in the process of trying to isolate where the issue lies. Could you please advise what kind of Vivado warnings (generated during synthisis and implementation) could give rise to this error. Thanks.

0 Kudos
Newbie clarelai
Newbie
554 Views
Registered: ‎10-25-2018

Re: [Labtools 27-3165] End of startup status: LOW

I found a solution........

ERROR: [Labtools 27-3165] End of startup status: LOW" after FPGA programming
Insufficient external power supply can cause this issue. If power supply is insufficient, module restarts and FPGA content is erased. Vivado did not recognize this.

Link: https://wiki.trenz-electronic.de/display/PD/FAQ
0 Kudos