UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor @neha
Visitor
7,012 Views
Registered: ‎04-23-2016

chipscope problem

I used a BROM. I want to see it's output data at chipscope. but chipscope shows its last element only. 

means I have a BRAOM of size 1200 data, where 1200th address contains data 255. then chipscope shows only data 255 and address 1200. it did not show data from 0 to 1200, which I want to see.

 

Another problem is BROM also have a reset signal. which i applied on hardware with a switch. Either I apply reset or not chipscope shows 255 and address 1200. but in simulation if reset is not applied then it does not show any data.

 

So, I want to ask where i mistaken.Please help me in this. 

0 Kudos
2 Replies
Moderator
Moderator
6,984 Views
Registered: ‎07-01-2015

Re: chipscope problem

Hi @neha,

 

How you are accessing data from ROM? How you are connecting signals to chipscope?

It seems you have connected dout to probe in chipscope which is data of a particular address.

If possible share the code/project to have a look.

 

Thanks,
Arpan

Thanks,
Arpan
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Visitor @neha
Visitor
6,959 Views
Registered: ‎04-23-2016

Re: chipscope problem

For a test I write a code which contains only dcm ip core, i used given code for that

 

module dcm_test(
input wire clk_p,clk_n,reset,
output wire clk1);
wire clk2;
wire locked;
dcm myclock
(// Clock in ports
.CLK_IN1_P(clk_p), // IN
.CLK_IN1_N(clk_n), // IN
// Clock out ports
.CLK_OUT1(clk1), // OUT 100 Mhz clk shown as a output on chipscope window
.CLK_OUT2(clk2), // OUT 200 Mhz clk apply as a chipscope clk
// Status and control signals
.RESET(reset),// IN
.LOCKED(locked)); // OUT

endmodule

 

Here also either i apply reset or not it shows clk1 on chipscope.

 

I also attached my project files

0 Kudos