UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

PIPE Mode Simulation of Ultrascale Gen3 PCIe Endpoint Block (v4.3) fails

Highlighted
Visitor
Posts: 2
Registered: ‎05-19-2017

PIPE Mode Simulation of Ultrascale Gen3 PCIe Endpoint Block (v4.3) fails

Hi,

 

I am struggling with the PIPE Mode Simulation option using the Ultrascale Gen3 PCIe Endpoint Block (v4.3) in Vivado 2017.1

 

I would like to speed up simulation of my PCIe application using PIPE Mode Simulation as stated in PG156 page 229 but I can't get the PCIe link up when using the PIPE mode simulation option. "Normal" Simulation with transceivers works fine.

For reference I started the simulation in the example design of the IP to compare my set up with the example design. But the simulation in the example design does not run either.

After the system reset becomes de-asserted there are no more events in the example simulation:


[             4995000] : System Reset Is De-asserted...
run: Time (s): cpu = 00:00:46 ; elapsed = 00:17:34 . Memory (MB): peak = 921.070 ; gain = 0.000

 

Do I miss something out when configuring the IP-Core?

 

The only change I made was activating 'Enable External PIPE Interface' in the Customization GUI of the IP-Block.

 

Further, I can't find the mentioned files (xil_sig2pipe.v and phy_sig_gen.v PG156 page 229) in the IP folder.

 

 

Any help on this is much appreciated.

 

Kind regards,

Mark

Xilinx Employee
Xilinx Employee
Posts: 212
Registered: ‎08-02-2007

Re: PIPE Mode Simulation of Ultrascale Gen3 PCIe Endpoint Block (v4.3) fails

The fast link training can be achieved by set the parameter in the top level

  parameter PL_SIM_FAST_LINK_TRAINING = "TRUE",

Visitor
Posts: 2
Registered: ‎05-19-2017

Re: PIPE Mode Simulation of Ultrascale Gen3 PCIe Endpoint Block (v4.3) fails

Looks like the parameter PL_SIM_FAST_LINK_TRAINING is already set to TRUE. I checked both the endpoint and rootport core modules in the example design with ISIM. But the link does not come up

Xilinx Employee
Posts: 30
Registered: ‎12-10-2013

Re: PIPE Mode Simulation of Ultrascale Gen3 PCIe Endpoint Block (v4.3) fails

Hi Mark,

 

The two files you mentioned will be generated, but only show up in the SIM sources, rather than the main IP sources, and I believe will only be generated with the example design.

 

I recommend opening the example design with this, and utilizing the instantiation template in the board.v files.  This will provide both the Xilinx RP, and a 3rd party RP instantiation template, along with many notes on requirements for PIPE mode.  This will also create the xil_sig2pipe.v - which will allow a more convenient naming convention.  Often times we see the below because there is an issue with clocking or connections. 

 

Hope that helps get you going!