cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pulsar
Explorer
Explorer
1,451 Views
Registered: ‎04-16-2015

DMA on VC707 and AC701

Jump to solution

Hello all

 

I tried to make DMA/Bridge Subsystem for PCI Express on the boards VC707 and AC701
using "Create Block Design".

 

Document pg195-pcie-dma.pdf wrote:
"Supports UltraScale+™, UltraScale™,
Virtex-7® XT Gen3 (Endpoint), and 7 Series
2.1 (Endpoint) Integrated Blocks for PCIe.
7A15T and 7A25T are the only ones not supported"

 

But I did not find PCIexpress within IP Integrator/Create Block Design.

 

Is this Subsystem supported for VC707 and AC701 ?

 

Thank you.
Best regards,
Viktor
==========================================================
P.S.
I worked in Vivado2016.4 under Linux.

0 Kudos
1 Solution

Accepted Solutions
wh1t3w0lf
Observer
Observer
1,973 Views
Registered: ‎02-12-2014

Latest versions of the DMA subsystem for PCIe support older Gen2 devices. Please see the IP's changelog for the exact version this happened and thus inference what Vivado version you need to use it. I use the latest 2017.3 and can instantiate it for older V7 devices without issues.

View solution in original post

3 Replies
jagannath
Adventurer
Adventurer
1,403 Views
Registered: ‎08-10-2017

@pulsar

 

I have the same query as well.

Let me know if you find out. 

0 Kudos
wh1t3w0lf
Observer
Observer
1,974 Views
Registered: ‎02-12-2014

Latest versions of the DMA subsystem for PCIe support older Gen2 devices. Please see the IP's changelog for the exact version this happened and thus inference what Vivado version you need to use it. I use the latest 2017.3 and can instantiate it for older V7 devices without issues.

View solution in original post

pulsar
Explorer
Explorer
1,385 Views
Registered: ‎04-16-2015

Hiello,

 

Thank you very much,

 

Best regards,

Viktor.

 

0 Kudos