cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
fiv115917357
Observer
Observer
1,664 Views
Registered: ‎01-05-2015

In spite of Secure Boot disabled, but XDMA driver load still fails.

Hello all,

I am trying to use xdma( Xilinx_Answer_65444_Linux_Files_rel20180420.zip) in Ubuntu 18.04-LTS.There is no problem compiling, but it fails in 'make install'.

- SSL error:02001002:system library:fopen:No such file or directory: ../crypto/bio/bss_file.c:74
- SSL error:2006D080:BIO routines:BIO_new_file:no such file: ../crypto/bio/bss_file.c:81
sign-file: certs/signing_key.pem: No such file or directory

 

Regarding to the similar case in this forum,  the kernel module needs to be validated by a public-private key pair in recent Ubuntu. But,  I believe secure boot is disabled.

$ dmesg | grep Sec
[ 0.000000] secureboot: Secure boot could not be determined (mode 0)
[ 0.024000] Security Framework initialized
[ 12.831512] megaraid_sas 0000:eb:00.0: Secure JBOD support : No

$ sudo mokutil --sb-state

SecureBoot disabled

 

Does anyone have advice or any idea?

Yutaka

Tags (2)
0 Kudos
3 Replies
coryb
Moderator
Moderator
1,639 Views
Registered: ‎02-11-2014

Hello @fiv115917357,

We have not tested the current XDMA Linux driver (Xilinx_Answer_65444_Linux_Files_rel20180420.zip) in Ubuntu 18.04 LTS, so we cannot guarantee it will work as expected.

The SLL error you are running into is spoken about / fixed in the following thread: https://github.com/andikleen/simple-pt/issues/8

Thanks,
Cory

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
fiv115917357
Observer
Observer
1,585 Views
Registered: ‎01-05-2015

@coryb Thank you, I was just wondering that why secure boot can not be disabled.

Anyway, I could install xdma rev 20180420 to Ubuntu 18.04.

The kernel will refuse to load unsigned kernel from Ubuntu 16.04.  To cope with, I used DKMS framework.

 

#Install DKMS

sudo apt-get install dkms-dev
sudo apt-get install libdrm-dev

#Copy source tree

# xdma version is hardcorded in the version.h and should be same as directory name. And I moved include file to src folder.

$sudo mkdir /usr/src/xdma-2017.1.47
$sudo cp ./xdma/* /usr/src/xdma-2017.1.47/
$sudo cp ./include/libxdma_api.h /usr/src/xdma-2017.1.47/

#make following config file as  "dkms.conf" and put to /usr/src/xdma-2017.1.47

---

#
# Linux DKMS config script for xdma
#

PACKAGE_NAME="xdma"
PACKAGE_VERSION=2017.1.47
AUTOINSTALL=yes

CLEAN="'make' clean"

MAKE[0]="'make' all KVER=${kernelver}"
BUILT_MODULE_NAME[0]="xdma"
#BUILT_MODULE_LOCATION="."
DEST_MODULE_LOCATION[0]="/updates"
DEST_MODULE_NAME[0]="xdma"

---

#add dkms repository and build

$sudo dkms add -m xdma -v 2017.1.47

$sudo dkms build -m xdma -v 2017.1.47

 

I hope this information will help someone in the future.

Thanks, 

Yutaka

 

0 Kudos
coryb
Moderator
Moderator
1,557 Views
Registered: ‎02-11-2014

Hello @fiv115917357,

Thank you for this information. I will forward it to development.

Thanks,
Cory

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos