cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
4,327 Views
Registered: ‎03-27-2009

Is my PIO simulation succeed?

hi ,

 

My tool version is 10.1.03, I generated a endpoint block plus core V1.9 using the coregen and patched it to 1.9 rev4,

then I did the simulation for the PIO design using modelsim se plus 6.5. It looks to me that the simulation run well, the link is 

up around 223us, after that I ahve seen activities on both TX and RX interface, from the modelsim transcript it passed the test

for bar0 to bar6, however, I have seen the following message in transcript:

 

** Failure: Simulation Stopped.
#    Time: 314106 ns  Iteration: 4  Process: /board/dsport_inst/tx_app/tests_inst/tx_stimuli File: ../dsport/test_interface.vhd
# Break in Subprogram finish at ../dsport/test_interface.vhd line 1043
# Simulation Breakpoint: Break in Subprogram finish at ../dsport/test_interface.vhd line 1043
# MACRO ./wave.do PAUSED at line 58

 

I am a little bit confused if my simulation is successful, it somehow succeed in a sense that the link is up and bar0 to bar6 test passed,

but why it is saying "Failure ..."?

 

my full modelsim transcripts is attached.

 

thanks in advance for your info,

 

David C.

0 Kudos
2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
4,291 Views
Registered: ‎08-01-2007

Hi David,

 

Yes, your simulation did end successfully.  The "Failure" reported in ModelSim is not actually a failure--it is caused by the method used in the testbench to end the simulation.  If you take a look at the "test_interface.vhd" file, line 1043, you will see this:

 

 

procedure FINISH is

  variable  L : line;


begin
  assert (false)
    report "Simulation Stopped."
    severity failure;
end FINISH;

 

 

I believe you must use a "failure" severity in ModelSim to make the simulation stop, but I am not sure.  There may be some other possibilities you could change this to.

 

-Kyle

0 Kudos
Highlighted
Adventurer
Adventurer
4,276 Views
Registered: ‎03-27-2009

hi Kyle,

 

Very appreciated your response, I got it.

 

 

David C.

0 Kudos