UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor yyyli
Visitor
253 Views
Registered: ‎09-06-2019

PCIe device not detected

I am using XDMA IP in the ip integrator , but after I created bitfile and programed the fpga ( XC7VX690TFFG1157-2),the device can not be recognized via lspci command

can anyone help me with the problem?

Below is my block design

pcie_block.PNG

PS: I have used the IP catalog and created the example design and the device can be detected.

 

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
189 Views
Registered: ‎08-02-2007

回复: PCIe device not detected

Please verify if the pin assiment is the same as the example design.

also try a reboot 

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Visitor yyyli
Visitor
178 Views
Registered: ‎09-06-2019

回复: PCIe device not detected

Thanks for your reply!

But I found another question is that when I select Gen2(5.0Gb/s), there are timing violations.timing_violations.PNGAnd the Gen1 can run successfully.

How to solve this problem? 

0 Kudos