cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
561 Views
Registered: ‎03-22-2013

QDMA V2.0 (vivado 2018.2) AXI-ST C2H Status Port qid not working?!

Hi,

I've a perfect working NIC application (RX/TX C2H and H2C stream).

With this application, I've some counter on the C2H Status Port to have some feedback about packet drop and accpeted by the QDMA....
Unil now, everything is working well. But when I changed the queue ID of the C2H stream to 512 instead of 0, I lost the counting of drop and accpeted packet.

After some investigation, I see that the signal "axis_c2h_status_qid [10:0]" is always 0 which explain the behavior.

 

axis_c2h_statusaxis_c2h_status

How can I solve this issue becasue I want to have multiple C2H stream with different QueueID and be able to have statistic counter for each queue!

 

Best regards,

Christian Lambricht

0 Kudos
3 Replies
Highlighted
Moderator
Moderator
523 Views
Registered: ‎02-16-2010

Hi, @christian.lambricht 

What do you do when you try to change the qid to 512?

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Highlighted
499 Views
Registered: ‎03-22-2013

Hi,

To change the Queue ID of the C2H stream, I  change the configuration in my custom linux driver and change the qid presented in the custom user logic (fpga) and everything is working fine.... I've a fully working 10G Network card.

BUT, the status interface of the qdma  seems not reporting any packet accepted on the QID=512.... Qid stay at 0 (ILA trigger not egal to 0) 

Christian

 

0 Kudos
416 Views
Registered: ‎03-22-2013

Hi Xilinx,

I'm still stuck with that issue!!! If you don't know nothing about that, maybe you can tell me if it is resolve in the v 3.0 IP?

 

Thanks

Christian

0 Kudos