cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
koutsoub
Newbie
Newbie
3,175 Views
Registered: ‎06-08-2011

Why I can't find PCIe Device

I'm using ml507 and I'm facing problems with pci express. I downloaded the project "endpoint_blk_plus_v1_14" form xilinx in order to test the pcie port.

I pluged the fpga into an x16 port bus in pci tree i could not recognize the fpga. Later i tried the port x1 pcie but the problem still remains. Still i cannot locate the device in pic three. I can see only the two pci express bridges.

Also i tried windows7 and windows xp. The results were the same in both cases.

The DIP switches i used are all form the manuals and they are:

sw3 = 11010101

sw6 = 10101010

sw8 = 11111111. Also i tried for the sw8 dip switch the "00000011"

still no result.

 

Is there anything wrong with the dip switches? perhaps i should download to ML50X/cfg6 only the pcie_blk_plus_top.ace and remove the original ace file of the ml507?

I do not know what else should be wrong..

 

Any answer is welcomed!

Vasilis

0 Kudos
1 Reply
luisb
Xilinx Employee
Xilinx Employee
3,164 Views
Registered: ‎04-06-2010

Try the files from the zip file I uploaded in this thread:
http://forums.xilinx.com/t5/PCI-Express/ML507-PCIe-x1-Endpoint-Plus-Design-ml507-pcie-x1-plus-ZIP/td-p/151032/page/2

Let us know if this makes a difference?

Have you also verified that it fails with cold and warm boots?
0 Kudos