UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Voyager
Voyager
970 Views
Registered: ‎10-31-2016

ZCU106: PCIe not detected in ubuntu 14.0

Jump to solution

Hello, 

 

The host motherboard is MSI X370 GAMING PLUS, Mainboard, which supports Gen3 PCIe. I initiate XDMA and flash the IP example into the hardware which is connected to the host PCIe. 

For X4 configuration I set J162 to 3-4 

 

Thd XDMA configuration is refclk 100, x4, 256 AXI width, Gen 3. 

 

But after flashing the IP example, the board is not detected by PC host (ubuntu 14).

 

May I know some suggestion regarding this problem?

 

Best regards 

0 Kudos
1 Solution

Accepted Solutions
Voyager
Voyager
1,073 Views
Registered: ‎10-31-2016

Re: ZCU106: PCIe not detected in ubuntu 14.0

Jump to solution
The pins for pcie are not automatically detected or assigned. Hence have to do manually.
This solve the problem
3 Replies
Voyager
Voyager
929 Views
Registered: ‎10-31-2016

Re: ZCU106: PCIe not detected in ubuntu 14.0

Jump to solution

Additional information on the Artix 7 AC701 with gen2 X4 is detected by the ubuntu, whereas ZCU106 dont. Is there any step that I missed ?

0 Kudos
Voyager
Voyager
1,074 Views
Registered: ‎10-31-2016

Re: ZCU106: PCIe not detected in ubuntu 14.0

Jump to solution
The pins for pcie are not automatically detected or assigned. Hence have to do manually.
This solve the problem
Observer mark.harfouche
Observer
377 Views
Registered: ‎11-05-2014

Re: ZCU106: PCIe not detected in ubuntu 14.0

Jump to solution

Do you have a reference you followed to get simple communication between ubuntu and the ZCU106?

0 Kudos