UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
235 Views
Registered: ‎10-09-2018

spartan 6 - pcie not working

Jump to solution

 

Hello,

system- Spartan6 - PCIe

             Win10 - 64bit

             RWEverything(to interface FPGA with PC)

Board is detecting but data transfer is not happening

when i try to send data through PCIe from PC to FPGA using RWEverything in 32 bit system,communication happens fine but, same thing if i try with 64 bit Win version all data revert back as F.

Is this above software issue or IP core issue or Driver issue?

If driver issue,How to install perfect driver for it?

Does Xilinx provide any software or driver for interfacing FPGA with PC?

Any other thing i should take care?

dev.jpgdev_1.jpgrw_1.jpg

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor
163 Views
Registered: ‎10-09-2018

Re: spartan 6 - pcie not working

Jump to solution

@mdenzin 

I am using Jungo windriver development tool-30 days.

It did solve all of the above issues, so basically it was a driver problem.

2 Replies
Visitor mdenzin
Visitor
188 Views
Registered: ‎09-06-2019

Re: spartan 6 - pcie not working

Jump to solution

I am experiencing the same issue using RWEverything on a 64-bit windows system and an Ultrazed EG board on PCIe carrier card configured as an endpoint.

Is there any advice you have for a read/write utility for a windows 64 system?

0 Kudos
Highlighted
Contributor
Contributor
164 Views
Registered: ‎10-09-2018

Re: spartan 6 - pcie not working

Jump to solution

@mdenzin 

I am using Jungo windriver development tool-30 days.

It did solve all of the above issues, so basically it was a driver problem.