cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
avinashc
Explorer
Explorer
830 Views
Registered: ‎10-09-2018

spartan 6 - pcie not working

Jump to solution

 

Hello,

system- Spartan6 - PCIe

             Win10 - 64bit

             RWEverything(to interface FPGA with PC)

Board is detecting but data transfer is not happening

when i try to send data through PCIe from PC to FPGA using RWEverything in 32 bit system,communication happens fine but, same thing if i try with 64 bit Win version all data revert back as F.

Is this above software issue or IP core issue or Driver issue?

If driver issue,How to install perfect driver for it?

Does Xilinx provide any software or driver for interfacing FPGA with PC?

Any other thing i should take care?

dev.jpgdev_1.jpgrw_1.jpg

0 Kudos
1 Solution

Accepted Solutions
avinashc
Explorer
Explorer
758 Views
Registered: ‎10-09-2018

@mdenzin 

I am using Jungo windriver development tool-30 days.

It did solve all of the above issues, so basically it was a driver problem.

View solution in original post

2 Replies
mdenzin
Visitor
Visitor
783 Views
Registered: ‎09-06-2019

I am experiencing the same issue using RWEverything on a 64-bit windows system and an Ultrazed EG board on PCIe carrier card configured as an endpoint.

Is there any advice you have for a read/write utility for a windows 64 system?

0 Kudos
avinashc
Explorer
Explorer
759 Views
Registered: ‎10-09-2018

@mdenzin 

I am using Jungo windriver development tool-30 days.

It did solve all of the above issues, so basically it was a driver problem.

View solution in original post