UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
606 Views
Registered: ‎10-09-2018

system not detecting FPGA with PCIe add on card

Jump to solution

Hello,

I am using XILINX-SPARTAN 6-100T board by Numato.

My hardware is not getting detect when i insert it in PCIe slot of my system.

bit file or SPI Flash generally takes around 5 sec. to programmed FPGA.

PCIe slot can provide power,so no external power has been given.

 

softwares- Xilinx ISE 14.7

                 RW-Everything ( driver for communicating with pcie ) - using this software for sharing data.

system- Win 10-64 bit, i3,single lane PCIe

 

So what can be reason here?

Thanks!

Regards,

Avinash Chavan

         

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor
492 Views
Registered: ‎10-09-2018

Re: system not detecting FPGA with PCIe add on card

Jump to solution

@numatolab  pin assignment to reset signal was open. 

Now i have assigned pin config to it and it works fine.

Thanks!

0 Kudos
6 Replies
Xilinx Employee
Xilinx Employee
557 Views
Registered: ‎08-02-2007

回复: system not detecting FPGA with PCIe add on card

Jump to solution

1 try additional power supply instead of the slot power

2 reboot the host to rule out the config time issue 

3 any example design or golden image can be used to rule out the issue within the desing?

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Contributor
Contributor
536 Views
Registered: ‎10-09-2018

回复: system not detecting FPGA with PCIe add on card

Jump to solution

Hi @liy ,

-Checked with additional power supply with system restart, no changes.

-I am using already generated example design by xlinx from IP core.

Still card not gets detected.

Is there any other driver has to be installed?

Thanks!

0 Kudos
Xilinx Employee
Xilinx Employee
527 Views
Registered: ‎08-02-2007

回复: system not detecting FPGA with PCIe add on card

Jump to solution

Would you please verify if the pin assiment is correct?

try another host to see if this is a host related issue 

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
Newbie numatolab
Newbie
512 Views
Registered: ‎04-29-2019

Re: system not detecting FPGA with PCIe add on card

Jump to solution

Hi Avinash!

There could be a number of reasons why board isn't being detected in the system:

  1. Constraints could be inadvertently incorrect. Please check the pin assignments
  2. BIOS enumerates PCIe devices faster than FPGA can configure itself. In this case:
    • Try doing a "soft-reset" of the system after FPGA has configured itself.
    • Try increasing the SPI Flash configuration rate, compressing the bitstream and enabling 4x SPI Mode. This will result in much faster configuration.
  3. Check the pin assignment of PCIe Reset Signal

You could also test it with a another system having preferably Linux installed and list the PCIe devices connected to it using `lspci` command.

Thanks!

Numato Lab

0 Kudos
Contributor
Contributor
504 Views
Registered: ‎10-09-2018

Re: system not detecting FPGA with PCIe add on card

Jump to solution

@liy  I have checked with another host, still problem remains.

@numatolab I am using example design by Xilinx, in that ucf there is no pin assigned to reset signal. Is this can be issue?

I have checked with soft reset with external power on for board.

0 Kudos
Highlighted
Contributor
Contributor
493 Views
Registered: ‎10-09-2018

Re: system not detecting FPGA with PCIe add on card

Jump to solution

@numatolab  pin assignment to reset signal was open. 

Now i have assigned pin config to it and it works fine.

Thanks!

0 Kudos