cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
8,995 Views
Registered: ‎12-15-2011

ERROR in KCPSM3

hi everyone!

I'm using KCPSM3 for spartan-3AN starter kit.

In your working, there are the files fully: KCPSM3.EXE; ROM_form.vhd; ROM_form.v; ROM_form.coe; int_test.psm

I already have gone to Working directory in DOS command and using command:

>kcpsm3 int_test.psm

then the following error appear:

ERROR - This error was probably caused during an attempt to
        specify to run the program with either the executable
        or the PSM file in a remote location or network drive.
        Please place all files in a working directory and
        execute locally.

And I reported it in attachment file.

I can't understand why that is. Please, support me to solve it

thank you very much!

I'm Hung
0 Kudos
9 Replies
Highlighted
Xilinx Employee
Xilinx Employee
8,990 Views
Registered: ‎09-05-2007

Where exactly is your working directory? May be you are using a network drive, have a long path or spaces in the names of directories.

 

Please try placing all files into a directory called 'C:\temp' and see if it works.

Ken Chapman
Principal Engineer, Xilinx UK
Highlighted
Observer
Observer
8,988 Views
Registered: ‎12-15-2011

Thank for your support.

I follow your solution which use directory "C:\temp".

But still appear such error.

I am using Window 7.

I'm Hung
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,981 Views
Registered: ‎09-05-2007

Please see previous discussion...

 

http://forums.xilinx.com/t5/PicoBlaze/KCPSM3-and-WIN-7-32-bits/m-p/232061

 

 

Ken Chapman
Principal Engineer, Xilinx UK
0 Kudos
Highlighted
Observer
Observer
8,979 Views
Registered: ‎12-15-2011

Thanks!
But that link is about Window7 64bit.
And I don't find which same as above error.
Actually that you (Ken Chapman) created it, then I think you will solve this.
Thank for subsequent your solutions.
I'm Hung
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,955 Views
Registered: ‎09-05-2007

The KCPSM3 assembler is a DOS application written in 2005 and is not compatible with Win-7 (32-bit or 64-bit). Please write directly to me if you want to request a copy of the native-Windows KCPSM3 assembler discussed in the thread that I provided a link to above. Also note that this is supposed to be a temporary solution now that KCPSM6 in the main focus for new designs. Clearly you are using a Spartan-3AN Starter Kit at this time so I can understand your immediate requirement especially if you are unable to access a Win-XP or earlier operating system.

Ken Chapman
Principal Engineer, Xilinx UK
0 Kudos
Highlighted
Observer
Observer
8,897 Views
Registered: ‎12-15-2011

Thank Chapman very much!
I'm Hung
0 Kudos
Highlighted
Anonymous
Not applicable
8,493 Views

hi,i am trying to use the picoblaze implemented frequency counter using  KCPSM3...............its the same program given on xilinx frequence counter which is for Spartan 3E XC500E . but i am having a spartan 3 kit and i am trying to program it on spartan 3 ,i am getting some errors which i am unable to solve ...can some one help me with the errors............

 

the errors are:-

Pack:679 - Unable to obey design constraints (LOC=SLICE_X8Y29) which
   require the combination of the following symbols into a single SLICEM
   component:
       MUXCY symbol "processor/sel_shadow_muxcy" (Output Signal =
   processor/sel_carry<0>)
       MUXCY symbol "processor/zero_cymux" (Output Signal = processor/zero_carry)
   The carry muxes are not connected in the required manner.  Please correct the
   design constraints accordingly.

0 Kudos
Highlighted
Anonymous
Not applicable
8,491 Views

hi,i am trying to use the picoblaze implemented frequency counter using  KCPSM3...............its the same program given on xilinx frequence counter which is for Spartan 3E XC500E . but i am having a spartan 3 kit and i am trying to program it on spartan 3 ,i am getting some errors which i am unable to solve ...can some one help me with the errors............

 

the errors are:-

Pack:679 - Unable to obey design constraints (LOC=SLICE_X8Y29) which
   require the combination of the following symbols into a single SLICEM
   component:
       MUXCY symbol "processor/sel_shadow_muxcy" (Output Signal =
   processor/sel_carry<0>)
       MUXCY symbol "processor/zero_cymux" (Output Signal = processor/zero_carry)
   The carry muxes are not connected in the required manner.  Please correct the
   design constraints accordingly.

0 Kudos
Highlighted
Anonymous
Not applicable
8,476 Views

Respected Sir/Madam,

I  apologise to all readers for adding the threads other than the existing issue. I suggest you ignore my previous message.

 

thanking you..

0 Kudos