UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor finbarrlong
Visitor
4,018 Views
Registered: ‎06-26-2014

Microblaze - Modelsim loading issue - cannot find .mem file

Hi 

 

I created a block diagram using Vivado Version 2013.3, which contains a Microblaze (version 9.2) and ancillary ip components.

I have compiled the complete design in Modelsim (version 12.d and 12.e) but I get the following error when loading modelsim. 

 

# Loading work.system_lmb_bram_0(system_lmb_bram_0_arch)

# ** Fatal: (vsim-7) Failed to open VHDL file "system_lmb_bram_0.mem" in rb mode.

#

# No such file or directory. (errno = ENOENT)

#    Time: 0 ps  Iteration: 0  Process: /system_wrapper/system_i/microblaze_0_local_memory/lmb_bram/U0/native_mem_map_module/mem_map_module/line__3381

File: c:/Projects/Xilinx/kintex_x4_meet_timing/kintex_x4_sep_pll_gg_pcie.srcs/sources_1/bd/system/ip/system_microblaze_0_axi_intc_0/blk_mem_gen_v8_0/simulation/blk_mem_gen_v8_0.vhd

# FATAL ERROR while loading design

 

I created a file a .mem file "system_lmb_bram_0.mem" and placed it in the directory 

 

c:/Projects/Xilinx/kintex_x4_meet_timing/kintex_x4_sep_pll_gg_pcie.srcs/sources_1/bd/system/ip/system_microblaze_0_axi_intc_0/blk_mem_gen_v8_0/simulation/

 

but this did not solve the problem.

 

Does anyone have any idea where this issue is originating from and as to what possible course of action I could take to rectify it.

 

Thanks

Finbarr

 

 

Tags (1)
0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
4,008 Views
Registered: ‎07-01-2010

Re: Microblaze - Modelsim loading issue - cannot find .mem file

Hi ,

Can you please the mem file in the simulation directory?
.///kintex_x4_sep_pll_gg_pcie.sim/sim1/


Regards,
Achutha
---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
0 Kudos
Visitor finbarrlong
Visitor
3,998 Views
Registered: ‎06-26-2014

Re: Microblaze - Modelsim loading issue - cannot find .mem file

Hi Achutha

Yes, I did that but still get the same error.

Thanks

Finbarr

0 Kudos
Visitor finbarrlong
Visitor
3,930 Views
Registered: ‎06-26-2014

Re: Microblaze - Modelsim loading issue - cannot find .mem file

Hi
Has anyone got any other suggestions?
I even changed the version of Modelsim to most recent version 10.3b, but still have had no luck.
Thks
Fionbarra
0 Kudos