We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Newbie jk7448
Registered: ‎09-17-2007


I want to put picoblaze vhdl code on my fpga spartan-3an kit. But the code is not successsfully compiled.
errrors are like this:
Compiling vhdl file "D:/Xilinx92i/picoblaze/picoblaze.vhd" in Library work.
ERROR:HDLParsers:3312 - "D:/Xilinx92i/picoblaze/picoblaze.vhd" Line 251. Undefined symbol 'LUT1'.
ERROR:HDLParsers:3313 - "D:/Xilinx92i/picoblaze/picoblaze.vhd" Line 255. Undefined symbol 'FDR'.  Should it be: FoR?
ERROR:HDLParsers:3313 - "D:/Xilinx92i/picoblaze/picoblaze.vhd" Line 261. Undefined symbol 'FDS'.  Should it be: FS?
ERROR:HDLParsers:1209 - "D:/Xilinx92i/picoblaze/picoblaze.vhd" Line 267. FDS: Undefined symbol (last report in this block)
ERROR:HDLParsers:1209 - "D:/Xilinx92i/picoblaze/picoblaze.vhd" Line 285. FDR: Undefined symbol (last report in this block)
ERROR:HDLParsers:3312 - "D:/Xilinx92i/picoblaze/picoblaze.vhd" Line 294. Undefined symbol 'LUT4'.
ERROR:HDLParsers:3312 - "D:/Xilinx92i/picoblaze/picoblaze.vhd" Line 307. Undefined symbol 'FD'.
ERROR:HDLParsers:3312 - "D:/Xilinx92i/picoblaze/picoblaze.vhd" Line 316. Undefined symbol 'FDE'.
ERROR:HDLParsers:1209 - "D:/Xilinx92i/picoblaze/picoblaze.vhd" Line 322. FDE: Undefined symbol (last report in this block)
Can anyone help?

0 Kudos
8 Replies
Xilinx Employee
Xilinx Employee
Registered: ‎09-05-2007

Re: Picoblaze

All the 'undefined symbols' being reported are elements in the 'unisim' library which is part of the standard Xilinx ISE installation. Near the top of the 'kcspm3.vhd' file is the declaration of this library.... 

library unisim;
use unisim.vcomponents.all;

I can only imagine that you are attempting to synthesize PicoBlaze on a platform which does not have a correct installation of the Xilinx ISE tools or something is preventing your synthesis tool from accessing the libraries. Normally this is all totally automatic for XST users and requires no special set up. Focus on how your set up responds to the unisim library declaration as that is the cause of all other messages that follow. 





Ken Chapman
Principal Engineer, Xilinx UK
0 Kudos
Newbie jk7448
Registered: ‎09-17-2007

Re: Picoblaze

thank you very much:smileyhappy:
This library was in the code, but commented and i didn't notice..now it works.

0 Kudos
Visitor smartsoft
Registered: ‎10-09-2007

Re: Picoblaze

Hi Ken,

I also have the same problem I think. I want to put bv arithmetic code for my fpga virtex4. Actually there are some replacement of code that I made.

these are the changes (standard code for bv_arithmetic.vhdl):
  function itobv (int : in integer;
                                length : in natural) return bit_vector;

i replace with (code taken from bvarithm.vhdl for synopsys):
  FUNCTION itobv(ARG: INTEGER; SIZE: INTEGER) return BVSIGNED;   <-------- the error refers to this line

The error below occur when I compile it. I've tried declaring the 'unisim' library as you mentioned. The error still occur. Does anyone can help me?

Compiling vhdl file "D:/....../wavelet2/bv_arithmetic-.vhd" in Library work.
ERROR:HDLParsers:3312 - "D:/....../bv_arithmetic-.vhd" Line 71. Undefined symbol 'BVSIGNED'.
ERROR:HDLParsers:1209 - "D:/....../bv_arithmetic-.vhd" Line 71. BVSIGNED: Undefined symbol (last report in this block)

Thanks in advance..
0 Kudos
Visitor smartsoft
Registered: ‎10-09-2007

Re: Picoblaze

anyone can help me?? nobody??
0 Kudos
Xilinx Employee
Xilinx Employee
Registered: ‎08-06-2007

Re: Picoblaze

Not sure what bvarithmetic is but you need to make sure that your code can find the VHDL definitions in bvarithmetic package.
This can be done with the "library" and "use" statements.
I always use the IEEE numeric package and add this to my VHDL file
library IEEE;
use IEEE.numeric_std.all;
0 Kudos
Newbie likeelikee
Registered: ‎05-28-2008

Re: Picoblaze

if somewhere haven't semicolon necessary,there will be a warning like you says.
0 Kudos
Visitor vimalbang
Registered: ‎11-16-2011

Re: Picoblaze

Hi ,

only VHDL file support in picoblaze. I am new in xilinx and i  know only verilog coding  and i want to know how to configure picoblaze controller.

0 Kudos
Teacher eteam00
Registered: ‎07-21-2009

Re: Picoblaze

only VHDL file support in picoblaze.


I'm using Verilog (kcpsm3.v and kcpsm6.v) with no problem.  You should check your PicoBlaze downloads for these files.

If you continue to have a problem, you should start a new thread.  Your topic is unrelated to this existing thread.


-- Bob Elkind

README for newbies is here: http://forums.xilinx.com/t5/New-Users-Forum/README-first-Help-for-new-users/td-p/219369

1. Read the manual or user guide. Have you read the manual? Can you find the manual?
2. Search the forums (and search the web) for similar topics.
3. Do not post the same question on multiple forums.
4. Do not post a new topic or question on someone else's thread, start a new thread!
5. Students: Copying code is not the same as learning to design.
6 "It does not work" is not a question which can be answered. Provide useful details (with webpage, datasheet links, please).
7. You are not charged extra fees for comments in your code.
8. I am not paid for forum posts. If I write a good post, then I have been good for nothing.
0 Kudos