cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Newbie
Newbie
4,887 Views
Registered: ‎05-08-2008

About the user defined instruction in APU

Hi, all,

 

I am using ML410 board and EDK 8.2. I am trying to make a PPC system with APU support. I used the default UID setting, and set the control configuration register to "0x0001". In the software, I define the related user defined instruction 1 as "#define UDIFCM(a, b, c) __asm__ __volatile__("udi0fcm " #a "," #b "," #c)" and add the "mtmsr(XREG_MSR_APU_AVAILABLE)" in the applicaiton. I simulated the system by using modelsim 6.0. In the simulation, everytime when the UDIFCM comes, the APU always gives a pulse on the singnal "APUFCMFLUSH", however, the singnals "APUFCMDECUDI, APUFCMDECODED..." which should be "1" when decoding the UID keep "0". It looks like the APU can not recognize the UID. And also the actual value of the instruction does not match the UID register value. I tried to use the pre-defined load/store instruction follow the xapp 717, they worked fine. Could anyone give me some hints for the APU-UID? That will appreciated if someone can share his experience!

 

Regards,

luyi  

0 Kudos
0 Replies