cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
4,230 Views
Registered: ‎01-22-2014

Booting ZC702 from SD card.


I have recently updates to Vivado 2013.4

 

When a create a new project for ZC702 (revision 1.0), export to SDK, create new first stage bootloder, create a BOOT.BIN and place onto a SD card then the board fails to boot.

 

Rebuilding with FSBL_DEBUG_INFO defined I get::

 

Xilinx First Stage Boot Loader
Release 2013.4 Jan 21 2014-13:07:27
Devcfg driver initialized
Silicon Version 1.0
Boot mode is SD
SD: rc= 0
SD: Unable to open file BOOT.BIN: 3
SD_INIT_FAIL
FSBL Status = 0xA009

This Boot Mode Doesn't Support Fallback
In FsblHookFallback function


The problem looks a lot like:

http://forums.xilinx.com/t5/General-Technical-Discussion/Unable-to-boot-FSBL-from-SD-on-zc706/m-p/398849/highlight/true#M16587


which referes to:

http://www.xilinx.com/support/answers/52023.html Howerver this fix seems to be in XSdPs_SdCardInitialize(..)


If I repeat the same process with Vivado 2013.3 then the FSBL works OK.


Any ideas?


Andy

 

 

0 Kudos
3 Replies
Highlighted
Visitor
Visitor
4,201 Views
Registered: ‎01-22-2014

I have a similar problem.  ZC702 Rev 1.0 board will not boot from SD card with Xilinx files in release 2013.4, found here http://www.wiki.xilinx.com/Zynq+2013.4+Release.  MD5 checksum was verified. 

 

0 Kudos
Highlighted
Visitor
Visitor
4,148 Views
Registered: ‎01-22-2014

I've just tried with a 8G SanDisk Extreme Pro SDHC Card (speed class 10) and  the first stage bootloader boots OK.

 

Previosuly I was using the  regular 8G SanDisk SDHC Card (speed class 4) that came with the evaluation board.

 

Look likes there is some timing on the edge.

 

Both cards work beyond the first stage bootloader and I can read and write both cards OK. I am using e-boot and the windows CE BSP provided by Adeneo Embedded.

 

I would still like to resolve this issue since soon we will be creating custom hardware.

 

Andy

 

 

 

0 Kudos
Highlighted
Visitor
Visitor
4,111 Views
Registered: ‎01-22-2014

Andy, thanks for pointing that out.

 

I switched to Class 10 and now the Xilinx files seem to boot fine from SD.

 

0 Kudos