cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sammy_verslype
Observer
Observer
3,893 Views
Registered: ‎03-26-2008

Bootloader hangs in the middle of copying image

Hi,

 

I'm using a bootloader to load my application, which is stored in flash, into DDR2 RAM. When powering the board the loader begins and I can see the progress in my terminal window. Thing is, that it just stops after copying the first 2 lines of the image. After that nothing happens. No error, nothing..

 

Are there any tools available to debug this? At first it should be very helpfull if I could find if the problem is situated in the bootloader software or in the synthesized hardware. I'm using the bootloader that is automatically generated with XPS.

 

thanks

0 Kudos
3 Replies
dylan
Xilinx Employee
Xilinx Employee
3,890 Views
Registered: ‎07-30-2007

I would start with checking the DDR memory.  If it is failing on the first access or so, the memory controller is likely not calibrating, and so will hang the bus when accessed.  Try to perform a simple memory test. 

I hope this helps,

Dylan

0 Kudos
sammy_verslype
Observer
Observer
3,882 Views
Registered: ‎03-26-2008

I checked with downloading the .elf with XMD into DDR ram and then everything works fine. Could it be that the bootloader can't access the memory for whatever reason allthough the memory is working fine?

 

Sammy

0 Kudos
kblommen
Visitor
Visitor
3,865 Views
Registered: ‎01-11-2011

 


@sammy_verslype wrote:

I'm using a bootloader to load my application, which is stored in flash, into DDR2 RAM. When powering the board the loader begins and I can see the progress in my terminal window


Can you tell me how you did this? I'm using the xapp1026 version and the echo server.
Best regards

 

0 Kudos