cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
3,079 Views
Registered: ‎03-25-2014

Cannot stop processor (Vivado 2016, Zed Board, Win 10)

Hello everyone,

 

I'm new to the Zynq platform and Vivado (I've experiance with spartan devices and ISE).

 

I'm currently going through tutorials to make me familiar with the whole design process. 

 

Atm. I'm stuck with Linux Boot over JTAG (These are the supposed steps in xilinx sdk):

 

1.) Program FPGA (Doesn't change anything if I skip this)

2.) Open XSCT console

3.) Set target 2 (Processor 0, target shows me that both processors are running)

4.) source {tcl init script}

5.) ps7_init (also tried ps7_post_config after)

6.) dow {u-boot image}

7.) con to start

8.) watch the serial output of u-boot and hit a key

9.) stop to hold the device

10.) dow {linux images}

 

The first thing that bothers me is that 5.) takes about 5 min. to finish and shows a warning about reading a write only register.

 

Normally the xsct hangs after step 6.), i see that the image gets downloaded and the console writes "(target 2) Stopped at 0xFFFFFF28 (Suspended)" after that the console doesn't react any more and no further xsct% prompt is shown.

 

Some times step 6.) worked and showed me the PC got set to 0x40000000. After that I could enter con and see u-boot startup on the serial terminal, but when I enter stop in xsct I get the same reaction as in 6.): "(target 2) Stopped at 0xFFFFFF28 (Suspended)" and the console hangs.

 

I've also tried to stop the target directly after step 3. Most of the time the console also hangs, but one time it succeeded and step 5.) afterwards finished immediately but than It also hangs in 9.)

 

Atm I'm using the onboard digilant jtag programmer, I had some problems with it when using it in combination with a usb hub but since I connected it directly to my pc it seems to work. I also habe a "xilinx platform cable usb II" but it seem as the hw server cannot detect it maybe someone can give me also a hint on because I've read that it should work with the hw server.

 

Please somebody can give me a hint what I'm doing wrong or were I can start to look for errors as there is nothing written in the console it just hangs?

 

 

 

 

 

 

 

Tags (1)
0 Kudos
1 Reply
Highlighted
Xilinx Employee
Xilinx Employee
3,046 Views
Registered: ‎08-01-2008

check these links
https://www.xilinx.com/support/answers/51787.html
https://forums.xilinx.com/t5/Zynq-All-Programmable-SoC/Zedboard-cannot-stop-the-processor-after-reset/td-p/653332
https://forums.xilinx.com/t5/Embedded-Processor-System-Design/Reset-one-of-the-Zynq-APUs/td-p/439742
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos