cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ggillett
Contributor
Contributor
948 Views
Registered: ‎08-14-2018

ERROR: [BD 41-237] Bus Interface property FREQ_HZ does not match between ...

Jump to solution

Hi,

I am encountering the title error when using a custom IP, it appears the slave AXI bus FREQ_HZ gets set to 100 MHz by default.  After adding the IP to a block diagram the parameter propagation fails while validating the BD.

INFO: [xilinx.com:ip:clk_wiz:6.0-1] /pll_0 clk_wiz propagate
ERROR: [BD 41-237] Bus Interface property FREQ_HZ does not match between /axil_IP_example_0/S_AXI(100000000) and /GP_interconnect/s00_couplers/auto_pc/M_AXI(125000000)
ERROR: [BD 41-238] Port/Pin property FREQ_HZ does not match between /axil_IP_example_0/S_AXI_ACLK(100000000) and /pll_0/clk_out1(125000000)

Looking at the solution here I read "Another thing you can try is to remove the FREQ_HZ parameter of your IP with the slave interface."

Where does this default get set? 

Where is the FREQ_HZ property in the IP? It does not appear in the property list of

 

ipx::get_bus_interfaces S_AXI -of [ipx::current_core]

or 

ipx::get_ports S_AXI_ACLK -of [ipx::current_core]

 

 

 

Any pointers appreciated. 

 

0 Kudos
1 Solution

Accepted Solutions
ggillett
Contributor
Contributor
909 Views
Registered: ‎08-14-2018

It turns out that adding the FREQ_HZ parameter to the bus interface allows propagation. It needs to be added not removed, as the quoted solution suggests. 

View solution in original post

0 Kudos
2 Replies
ggillett
Contributor
Contributor
928 Views
Registered: ‎08-14-2018

Addendum:

I found this IP packager GUI dialogue.

busparams.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

It appears that the FREQ_HZ property can be added but only as a parameter that requires the user to set it.

There must be a way to have this propagate in the BD, what I am I missing?

0 Kudos
ggillett
Contributor
Contributor
910 Views
Registered: ‎08-14-2018

It turns out that adding the FREQ_HZ parameter to the bus interface allows propagation. It needs to be added not removed, as the quoted solution suggests. 

View solution in original post

0 Kudos