cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
rtg
Observer
Observer
2,814 Views
Registered: ‎05-23-2017

Error in using Open Picoblaze Assembler

Jump to solution

I am using the Opbasm 1.3 but I am always getting the error "ERROR: Address exceeds memory bounds:400".  I have tried different programs.  It showed up even on the sample "auto_baud_rate_control.psm" which is provided with picoblaze.  It worked fine with the default assembler.  Please provide any assistance, if possible.

 

Thanks.

0 Kudos
1 Solution

Accepted Solutions
rtg
Observer
Observer
4,939 Views
Registered: ‎05-23-2017

Hi. I found the solution.  Using -r when compliling it through the terminal, it removes the dead code.  It worked fine after that.

View solution in original post

0 Kudos
2 Replies
rtg
Observer
Observer
4,940 Views
Registered: ‎05-23-2017

Hi. I found the solution.  Using -r when compliling it through the terminal, it removes the dead code.  It worked fine after that.

View solution in original post

0 Kudos
paebbels
Explorer
Explorer
2,275 Views
Registered: ‎04-24-2014

Yes, OPBASM optimizes code (dead code elimination) There are settings and pragmas to control dead code elimination and code preservation. See the detailed documentation on GitHub for more details.

0 Kudos