cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
344 Views
Registered: ‎11-29-2018

MIO pushbutton configuration for gpio

Respected Sir

I am trying to do this same example design that Xilinx has provided i.e blinking of PS LED (DS50) from a PS Push Button (SW19). 

embeddedsw/XilinxProcessorIPLib/drivers/gpiops/examples/xgpiops_polled_example.c 

In Vivado I have only enabled MIO 0 Bank before running connection Automation , rest I have not enabled anything.

But still after pressing PS Push Button DS50 is not blinking . I don't know what I am doing wrong . Can You please Suggest Something.

Regards

Manisha Naryal

 
 
0 Kudos
1 Reply
Highlighted
Xilinx Employee
Xilinx Employee
283 Views
Registered: ‎07-12-2018

Re: MIO pushbutton configuration for gpio

Hi zuzu@123 

Did you debug adding some print statements?

Here you have configured two GPIOs, may I know how you have configured? 

Is an interrupt generated when you push the button? 

Please share the snippet code and PS configuration if possible, will try to reproduce the issue.

 

Best Regards
Abhinay PS
------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------

0 Kudos