cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
5,289 Views
Registered: ‎10-01-2014

MicroBlaze program does not run in debugger

Jump to solution

Hi.

I'm working with an AVNET LX150T Spartan-6 kit. I have been able to compile and download a very basic LED setting code. When I launch the debugger it seems to start ok (I can see the arrow pointing to the very begining of main() routine). However when I press the RUN buttom I see this message:

 

Error starting process.

Cannot run program "C:\JCR\workspace\quasimodo\Debug\quasimodo.elf": Launching failed

Cannot run program "C:\JCR\workspace\quasimodo\Debug\quasimodo.elf": Launching failed

Cannot run program "C:\JCR\workspace\quasimodo\Debug\quasimodo.elf": Launching failed

 

And nothing happens. There is no other failure indication, only this message.

Does anyone have a hint?

Thanks

Joao

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
9,251 Views
Registered: ‎08-02-2007

Hi,

 

Are you able to run the elf using XMD prompt?

 

The procedure to do this is:-

 

  1. Go to EDK GUI -> Project -> Launch EDK Shell
  2. Type the command “xmd” in the shell prompt
  3. Go to the location where you have stored the bitstream and ELF
  4. Type the command “fpga -f download.bit”
  5. Once the FPGA is programmed type the command “connect mb mdm”. This will connect to the processor
  6. Type “dow executable.elf”
  7. Type “run” or “con”

--Hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
9,252 Views
Registered: ‎08-02-2007

Hi,

 

Are you able to run the elf using XMD prompt?

 

The procedure to do this is:-

 

  1. Go to EDK GUI -> Project -> Launch EDK Shell
  2. Type the command “xmd” in the shell prompt
  3. Go to the location where you have stored the bitstream and ELF
  4. Type the command “fpga -f download.bit”
  5. Once the FPGA is programmed type the command “connect mb mdm”. This will connect to the processor
  6. Type “dow executable.elf”
  7. Type “run” or “con”

--Hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
Highlighted
Visitor
Visitor
5,231 Views
Registered: ‎10-01-2014

Yes, it works this way.

Thanks a lot

0 Kudos