cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
zhch777777
Participant
Participant
948 Views
Registered: ‎10-27-2017

R5 APP cant print UART1

hi:

      i  build a project by ug1209. and use isolation setting as same as ug1209. and create boot.bin only using fsbl_a53.elf,pmu_fw.elf and testapp_r5.elf.the uart1 cant print anything.but when use fsbl_r5.elf.the uart1 can print "Hello World from R5-0 displayed on UART-1".

    when i set #define FSBL_PROT_BYAPSS_EXCLUDE_VAL      (0U) ,     all the uart1 can print print "Hello World from R5-0 displayed on UART-1".

    i use vivado 2018.2,petalinux,2018.2,ubuntu16.4,and zcu102 R1.1

    how can i set isolation, the uart1 can print by fsbl_a53  booting?   thanks

0 Kudos
4 Replies
stephenm
Xilinx Employee
Xilinx Employee
940 Views
Registered: ‎09-12-2007

0 Kudos
zhch777777
Participant
Participant
895 Views
Registered: ‎10-27-2017

thanks for reply.

     yes ,i have tried  AR#71015.

     1,Subsystem: RPU Master: RPU0 (Secure) Slave CRL_APB (Secure), RPU (Secure).R5 app can't work.UART1 can't print anything.

      2.#define FSBL_PROT_BYAPSS_EXCLUDE_VAL      (0U) .UART1 can print "hello world". but i want know how set isolation to make R5 app printing  "hello world"  .

 

      i find  testapp_r5.elf can work well in  the ug1209 Tutorial zip file,but the edt_zcu102_wrapper.hdf in zip is different from edt_zcu102_wrapper.hdf which is generated by SDK with the ug1209 Tutorial .how the  edt_zcu102_wrapper.hdf in zip

set isolation setting?

0 Kudos
zhch777777
Participant
Participant
872 Views
Registered: ‎10-27-2017

hi: 

      someone know this problem?thanks

0 Kudos
wenhaohuang
Participant
Participant
802 Views
Registered: ‎02-10-2017

Hi,I have this problem too. Do you have any soluation?

0 Kudos