cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
1,507 Views
Registered: ‎07-26-2012

UART Communication on COM Port freezes, but JTAG UART works fine

Hi everyone,

 

I am very new to Xilinx EDK. I am working with EDK 14.1 and spartan 3E starter board. I did some basic UART communication using "print()" function and I was able to recieve data on Hyperterminal. 

 

However, when I started using some functions like xil_printf and GpioInputExample from the peripheral_test example, the COM port started to freeze and there was no output available. Even the program stuck and I had to terminate it manually. Now when I changed the STDIO Connection to JTAG URT, the same program worked great. Even I have checked the output with XMD console and it appears to work fine. But again when I changed the STDIO Connection to COM1 (in my case), the program got stuck. I debugged and saw that the program gets stuck everytime executing a function "while (XUartLite_IsTransmitFull(BaseAddress));" which is a line in XUartLite_SendByte() function declaration.

 

On the same session, I started running the peripheral_test example with COM1 as STDIO and this peripheral_test example worked and I receieved output on hyperterminal. I dont understand where the error is?

 

Please help.  

 

Thank you in advance, 

 

Pallab.

Tags (1)
0 Kudos
0 Replies