cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mikedeeds
Newbie
Newbie
847 Views
Registered: ‎02-23-2018

Ultrascale+ PS SPI Master

Jump to solution

I can't figure out how to enable the PS SPI Master pins in the Ultrascale+.

 

When I enable SPI0 or SPI1 and select a set of MIO pins, I only see si and so pins assigned.  I should see mi and mo pins when SPI is used as a SPI Master.  Is there somewhere that I need to enable the SPI peripheral as a master?

 

Here is the Vivado setup page:

 

Thank you!

 Ultrascale+ SPI configuration.jpg

0 Kudos
Reply
1 Solution

Accepted Solutions
pvenugo
Moderator
Moderator
1,000 Views
Registered: ‎07-31-2012

Hi @mikedeeds,

 

Here in particular Vivado version PCW, the naming conventions is such that the so is MISO and si is MOSI lines.

The master is enabled.

 

Regards

Praveen


-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
Reply
2 Replies
pvenugo
Moderator
Moderator
1,001 Views
Registered: ‎07-31-2012

Hi @mikedeeds,

 

Here in particular Vivado version PCW, the naming conventions is such that the so is MISO and si is MOSI lines.

The master is enabled.

 

Regards

Praveen


-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
Reply
mikedeeds
Newbie
Newbie
723 Views
Registered: ‎02-23-2018

Thank you! This answers my question.

0 Kudos
Reply