cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
yuji_isobe
Visitor
Visitor
340 Views
Registered: ‎05-30-2021

Unable to re-edit custom IP.

Jump to solution

Hi:

 

When I edit a custom IP in [Edit in IP Packager] in [Vivado 2021.1], the following error occurs.

Spoiler
ERROR: [Board 49-71] The board_part definition was not found for digilentinc.com:arty-z7-20:1.0. The project's board_part property was not set, but the project's part property was set to xc7z020clg400-1. Valid board_part values can be retrieved with the 'get_board_parts' Tcl command. Check if board.repoPaths parameter is set and the board_part is installed from the tcl app store.

 

The new vivado session that appears afterwards does not have Design Soureces.カスタムIP非表示エラー - コピー (2).png

  What should I do to solve the problem?

  Thanks very much!

 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
vsrunga
Xilinx Employee
Xilinx Employee
327 Views
Registered: ‎07-11-2011

Hi,

I tried something similar and don't see any error.

Are you on windows ?

May be you downloaded "digilentinc.com:arty-z7-20:part0:1.0" from Vivado_store to your local repository which has access to the original project but not the edit IP temp project 

Can you type below command in original project and in temp project's Vivado TCL console and analyze the result ?

get_board_parts *digilentinc.com:arty-z7-20:part0:1.0*

report_property -all [get_board_parts *digilentinc.com:arty-z7-20:part0:1.0*]

 

If the first command returns null in the temp project, place the board files in some global location like install dir and rerun the flow 

---------------------------------------------------------------------------------------------
Please do google search before posting, you may find relavant information.
Mark the post - "Accept as solution" and give kudos if information provided is helpful and reply oriented

View solution in original post

3 Replies
vsrunga
Xilinx Employee
Xilinx Employee
328 Views
Registered: ‎07-11-2011

Hi,

I tried something similar and don't see any error.

Are you on windows ?

May be you downloaded "digilentinc.com:arty-z7-20:part0:1.0" from Vivado_store to your local repository which has access to the original project but not the edit IP temp project 

Can you type below command in original project and in temp project's Vivado TCL console and analyze the result ?

get_board_parts *digilentinc.com:arty-z7-20:part0:1.0*

report_property -all [get_board_parts *digilentinc.com:arty-z7-20:part0:1.0*]

 

If the first command returns null in the temp project, place the board files in some global location like install dir and rerun the flow 

---------------------------------------------------------------------------------------------
Please do google search before posting, you may find relavant information.
Mark the post - "Accept as solution" and give kudos if information provided is helpful and reply oriented

View solution in original post

watari
Professor
Professor
319 Views
Registered: ‎06-16-2013

Hi @yuji_isobe 

 

Would you refer the following git repository to add board design into Vivado ?

 

https://github.com/Digilent/vivado-boards

 

Best regards,

yuji_isobe
Visitor
Visitor
255 Views
Registered: ‎05-30-2021

Thank you for your answer.

It worked fine by installing it from the Vivado Store in Tasks.

0 Kudos