cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
trm61
Visitor
Visitor
1,532 Views
Registered: ‎06-25-2017

Unable to run initial IPI tests on new KCU105

Unable to get any support and this is very time urgent, so reposting with complete summary

 

I am walking through the initial KCU105 Software Install and Board Setup and while I can get the Configuration terminal to work just fine, I cannot get the UART terminal to display anything!

 

The UART does in fact work, as I verified with a reference design, but I cannot get it to work with the INI tests and I must run these tests and very all components before the 30 day return time expires!!

 

I have tried both USB drivers 6.7.4 and 6.7, nothing changes.

I am running on Windows 10 and the ports both show up and are OK in Windows, just cannot communicate with the KCU105.

I can walk through clock and other configuration options, make changes, etc. all is fine, but I cannot get the tests to show up in the other terminal.

 

Note that power on BIST tests all pass, just cannot get through the IPI tests.

All jumpers are correct and I switched cables and USB ports to debug.

 

Note that I am a design engineer with more than 30 years computer and networking experience, so it is not a user issue.

There seems to be something missing, please advise.

I followed the instructions to the letter, as well as tried everything I know.

 

Thank you!

0 Kudos
1 Reply
trm61
Visitor
Visitor
1,447 Views
Registered: ‎06-25-2017

OK, so after my grueling move I went searching again and just happened to stumble on the "KCU105 IP Integrator Application" document...

 

I had been entirely in the "KCU105 Software Install and Board Setup" document and had no knowledge of the other document, as I could not find any references to any other documents, etc.

 

Once I followed the "KCU105 IP Integrator Application" instructions, the menu came right up.

Though, the iic_read test is hanging, the clocking test fails 8 clocks, though that might be expected, not sure, and a couple of other tests are failing.

 

I don't have everything connected, so I need to connect everything and rerun the tests and go from there, but at least the tests show up and run.

I am not sure why the setup instructions do not refer to the IP Integrator document, would have saved a lot of wasted time.

0 Kudos