cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor
Visitor
5,278 Views
Registered: ‎07-15-2009

XPS_TFT on Spartan-3a DSP 3400a

Hello,

I'm doing my first steps with FPGAs and the Xilinx Tools and the LCD is already running :)
But now I'm trying to get the xps_tft IP running on my Spartan-3a devboard using EDK 11.2 but nothing happens on the tft.
Before I post a lot of code, please, can anyone tell me how do I figure out how I have to configure the pins (IOSTANDARD etc) in the system.ucf?
I attached some parts out of my system.ucf/.mhs, maybe anyone find the failure(s).

Thanks a lot,
Alex!
0 Kudos
3 Replies
Highlighted
Visitor
Visitor
5,172 Views
Registered: ‎01-21-2008

Re: XPS_TFT on Spartan-3a DSP 3400a

Has anyone already managed to get this working? I have found the pin configurations in the documentation and the reference documents, but the monitor does not receive sync signals.

The reference designs use other custom IP, but I would like to use the standard IP library only.

My guess is that some software initialization is missing (I2C programming).

Any help would be greatly appreciated.

 

Regards,

 

Tommy Kamps

0 Kudos
Highlighted
Visitor
Visitor
5,170 Views
Registered: ‎07-15-2009

Re: XPS_TFT on Spartan-3a DSP 3400a

I didn't continue trying to get the xps_tft working. Have you tried the sw examples in this thread?

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
5,168 Views
Registered: ‎04-23-2008

Re: XPS_TFT on Spartan-3a DSP 3400a

The XPS TFT attempts to configure the Chrontel DVI chip (using IIC) itself.  I believe the 3400 board has an IIC mux on this bus, and I don't know that the Chrontel is selected by default.  I think you will probably need to use an xps_iic core in your system, and configure the mux and Chrontel with your own software.

 

-Brian

0 Kudos