cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
8,034 Views
Registered: ‎05-31-2015

XPS error when configuring microblaze

Jump to solution

Hi,

 

I am working in spartan 6 XC6SLX45. I want to configure microblaze in it and is using xilinx XPS for same. But I am getting following error and duont know to solve it . Kindly make some suggestions.

 

EDK:3900 - issued from TCL procedure "check_error" line 12
C_MASK (IPNAME:lmb_bram_if_cntlr, INSTANCE:microblaze_0_i_bram_ctrl) - Can
not generate mask for the LMB peripherals! An address decode mask is assigned
to all LMB peripherals connected to the MicroBlaze processor. The address
decode mask is based on a set of decode bits that distinguish the LMB address
space from the OPB/PLB/AXI address space. The error message indicates that a
set of decode bits can not be found to generate a mask. Please modify the
address map of the slaves connected to OPB/PLB/AXI to use a common address
bit.
ERROR:EDK:4114 - IPNAME: lmb_bram_if_cntlr, INSTANCE: microblaze_0_i_bram_ctrl -
error computing override value for C_MASK using tcl -
C:\Xilinx\14.7\ISE_DS\EDK\hw\XilinxProcessorIPLib\pcores\lmb_bram_if_cntlr_v3
_10_c\data\lmb_bram_if_cntlr_v2_1_0.mpd line 92

 

ERROR:EDK:3900 - issued from TCL procedure "check_error" line 12
C_MASK (IPNAME:lmb_bram_if_cntlr, INSTANCE:microblaze_0_d_bram_ctrl) - Can
not generate mask for the LMB peripherals! An address decode mask is assigned
to all LMB peripherals connected to the MicroBlaze processor. The address
decode mask is based on a set of decode bits that distinguish the LMB address
space from the OPB/PLB/AXI address space. The error message indicates that a
set of decode bits can not be found to generate a mask. Please modify the
address map of the slaves connected to OPB/PLB/AXI to use a common address
bit.
ERROR:EDK:4114 - IPNAME: lmb_bram_if_cntlr, INSTANCE: microblaze_0_d_bram_ctrl -
error computing override value for C_MASK using tcl -

ERROR:EDK:3371 - Conversion to XML failed.

 

my address tab is also shown

 

xilinx_error.PNG

 

Thanks in advance.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Explorer
Explorer
14,871 Views
Registered: ‎05-31-2015

Re: XPS error when configuring microblaze

Jump to solution

Hi,

 

I have changed value of c_mask of lmb controllers.

View solution in original post

0 Kudos
3 Replies
Highlighted
Moderator
Moderator
7,970 Views
Registered: ‎02-16-2010

Re: XPS error when configuring microblaze

Jump to solution
Please check if the thread below is relevant to you
http://forums.xilinx.com/xlnx/board/crawl_message?board.id=EDK&message.id=28594
------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
7,934 Views
Registered: ‎08-02-2007

Re: XPS error when configuring microblaze

Jump to solution

hi,

 

can you assign an address to the bridge of axi_plb and the spi controller manually?

 

it looks that all of these are overlapping with lmb bram controller

 

--hs

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Explorer
Explorer
14,872 Views
Registered: ‎05-31-2015

Re: XPS error when configuring microblaze

Jump to solution

Hi,

 

I have changed value of c_mask of lmb controllers.

View solution in original post

0 Kudos