Showing results for 
Show  only  | Search instead for 
Did you mean: 
Registered: ‎10-17-2017

ZynqMP+ gets "Synchronous Abort" restarting cores 1-3



I'm trying to fire up the other 3 APU cores on the zynq ultrascale+,

but I keep getting:


"Synchronous Abort" handler, esr 0x96000010
ELR: 78521b40
LR: 78521ce0
x0 : 00000000ffd80110 x1 : 0000000078526070
x2 : 0000000078520924 x3 : 0000000078eccec0
x4 : 000000000000000f x5 : 000000000000001c
x6 : 0000000000000000 x7 : ffffffffffffffff
x8 : 00000000785263b8 x9 : ffffffffffffffff
x10: 0000000000000000 x11: 0000000000000002
x12: 00000000ffffffff x13: 00000000ffffffff
x14: 000000007ded6cbc x15: 000000007ff7ea60
x16: 0000000000008110 x17: 0000000000000000
x18: 0000000000000000 x19: 0000000078eccff0
x20: 000000007ff88730 x21: 0000000030000000
x22: 0000000000000000 x23: 000000007ff9d0b4
x24: 0000000000000002 x25: 000000007ded9040
x26: 000000007ff88730 x27: 0000000078520288
x28: 0000000000000000 x29: 0000000078eccf60

Resetting CPU ...

### ERROR ### Please RESET the board ###


when I try to fire one up.

I think I've set the cpu restart addresses correctly, and appear to have

powered it down and started it back up, but what is this error?

I need a clue to continue...


I've tried making various projects in the IDE and poking through

the boot code, but can't seem to find anything useful there.

And I've tried following the trusted boot code on github, which

seems more useful, but doesn't work either.


What's the best/easiest way to start up the other ACPUs?




0 Kudos
0 Replies