cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
5,049 Views
Registered: ‎01-20-2014

error for ZYNQ 7Z045 device for planahead IO pin planning

i am designing a custome ZYnq board for my application using ZYNQ 7z045 device. using ISE and XPS i designed the internal hardware configuration.for IO pin planning i selected IO pin planning using Planahead (post systhesis).

when planahead launches it is giving error messge as follows i dont know what to do.

 

ERROR: [Device 21-41] Device part file is invalid: [C:/Xilinx/14.7/ISE_DS/PlanAhead/data\./parts/xilinx/zynq/zynq/xc7z045/xc7z045.xng]

 

i am using ISE 14.7.

please help out of this as soon as possible.

Tags (2)
0 Kudos
6 Replies
Highlighted
Xilinx Employee
Xilinx Employee
5,044 Views
Registered: ‎09-20-2012

Hi,

 

Can you try this out?

 

In Planahead, create a IO planning project with this target part ZYNQ 7z045 and see if it succeeds.

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
0 Kudos
Highlighted
5,010 Views
Registered: ‎01-20-2014

sorry for the late reply.,

i tried that also., but it is also giving same error.

 

but i  generated same design in vivado HLS it is working there.

i think there is problem in part library in ISE 14.7.

whether you also facing same issue?

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
5,007 Views
Registered: ‎09-20-2012

Hi,

 

I tried creating an IO planning project in Planahead 14.7 using the same part. This went on fine.

 

looks like some install issue. Can you try using a different machine and see if that helps?

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
5,004 Views
Registered: ‎08-02-2007

Hi,

 

Quick question, are you using Webpack for the ISE Design Suite?

 

--Hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
4,980 Views
Registered: ‎01-20-2014

hi hem.,

i am using system edition of ISE 14.7

i went to the root directory of the error. i found that the .xng file is of 0KB size.

 

i think i have to install once again.,

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
4,978 Views
Registered: ‎09-20-2012

Hi,

 

Yes, please re-install ISE and this time after downloading the ISE, before installation verify the checksum of download.

 

Let us know if this is not fixed even after re-install.

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
0 Kudos