UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer mogarfield
Observer
376 Views
Registered: ‎08-08-2017

ARM_DAP is missing

Hi guys,

We made two boards based on ZYNQ and they are not able to connect to the ARM_DAP. We check all the voltages, clk waveform, boot setting, power and reset sequencing, PCB design, Vivado version, and they seem all right.

But when we use a capacitor or a probe of WaveRunner to touch on the pin of PS_clk, the Vivado is able to detect the ARM_DAP. After detection, the capacity or a probe of WaveRunner can be removed and the system goes well.

Further, we try to increase the decouple capacity for the power of oscillator which provides PS_clk , and find it's no help. It has already been 0.1uf. And the trace of PS_clk is very short and close to the pad, with ground shield and 50-ohm characteristic resistance. 

Anyone knows why?

 

0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
358 Views
Registered: ‎09-04-2012

Re: ARM_DAP is missing

I know that you mentioned that you looked at the power ramps, sequencing, reset, and clock but I would still suspect that it is related to either:

  • Power sequencing
  • Stable clock relationship to reset deasserted
  • Power/ground rail noise
  • Stable reset relationship to power ramp
  • Stable clock relationship to power ramp
  • Some noise on the JTAG signals during power ramp

Double-check these against the datasheet specifications.

Regards,

Christophe

0 Kudos