cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Voyager
Voyager
595 Views
Registered: ‎05-30-2018

AXI GPIO v2.0 functionality: interrupt isn't generated

Jump to solution

Hello,

 

Here is simple design aiming to check interrupt handling staff at ARM core:

button_interrupt_design.JPG

gpio_sws_3bits is wired to on-bord (ZC706) buttons

According to the AXI GPIO v2.0 manual interrupt is generated once there is an activity on input ports.

I check if this a true with ILA ... and see that nothing happens at axi_gpio_0_ip2intc_irpt line when I push buttons.

Where is a problem ?

Thanks.

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Voyager
Voyager
579 Views
Registered: ‎05-30-2018

Re: AXI GPIO v2.0 functionality: interrupt isn't generated

Jump to solution

Well, I forgot to toggle bit in status register once interrupt occurs.

So, now it's Ok.

View solution in original post

2 Replies
Highlighted
Voyager
Voyager
584 Views
Registered: ‎05-30-2018

Re: AXI GPIO v2.0 functionality: interrupt isn't generated

Jump to solution

Well ... I forgot to enable global interrupt (Global Interrupt Enable Register, GIER)  and  IP interrupt (IP Interrupt Enable Register, IP IER).

Once I enabled them, another problem: the interrupt line is always at '1'.

Highlighted
Voyager
Voyager
580 Views
Registered: ‎05-30-2018

Re: AXI GPIO v2.0 functionality: interrupt isn't generated

Jump to solution

Well, I forgot to toggle bit in status register once interrupt occurs.

So, now it's Ok.

View solution in original post