UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor liumxy
Visitor
6,256 Views
Registered: ‎01-09-2013

AXI processor with TFT controller

Jump to solution

Hello, I'm trying to use XPS TFT controller with an AXI microprocessor. The video frame buffer should be located in a DDR3, which can be accessed through axi interface. Although I have already suceeded to use the controller with a PLB microprocessor, it does not work with AXI.

 

The problem is, I can use SDK to debug and run the design and see all the "print()" messages. But my screen keeps dark. It seems that, it is not turned on. I tried one "axi to plb" bridge which has AXILITE on the axi side and also two bridges that have AXI and AXILITE. But the result is the same.

 

attached are my mhs and ucf files.

Any advice is welcome and appreciated.

Thank you!

 

0 Kudos
1 Solution

Accepted Solutions
Visitor liumxy
Visitor
8,049 Views
Registered: ‎01-09-2013

Re: AXI processor with TFT controller

Jump to solution

I found out that, both an axi to plb bridge and a plb to axi bridge are needed, as TFT controller attaced on the plb bus not only as a slave but also as a master. 

 

Hope it helps.

0 Kudos
6 Replies
Visitor liumxy
Visitor
6,252 Views
Registered: ‎01-09-2013

Re: AXI processor with TFT controller

Jump to solution

I am using ML605. Xilinx ISE design suite 14.4.

0 Kudos
Visitor liumxy
Visitor
6,239 Views
Registered: ‎01-09-2013

Re: AXI processor with TFT controller

Jump to solution

I think there may be problem with the AXI_PLB_Bridge.

Could anyone give me some advices on how to configure the bridge?

 

Thank you

0 Kudos
Adventurer
Adventurer
6,193 Views
Registered: ‎03-16-2010

Re: AXI processor with TFT controller

Jump to solution
I ran into the same issue; dark screen instead of a raw memory view upon start up. In my case I use XPS 13.4 and an AXI4 bus but so far its not working. Are there specific settings for the bridge to make AXI4 work with the xps_tft module?
0 Kudos
Visitor liumxy
Visitor
8,050 Views
Registered: ‎01-09-2013

Re: AXI processor with TFT controller

Jump to solution

I found out that, both an axi to plb bridge and a plb to axi bridge are needed, as TFT controller attaced on the plb bus not only as a slave but also as a master. 

 

Hope it helps.

0 Kudos
Visitor tunab
Visitor
4,760 Views
Registered: ‎10-17-2014

Re: AXI processor with TFT controller

Jump to solution
Hi,
I'm exactly trying to do same thing, but I couldn't achive it yet. I added both axi-plb and plb-axi bridges to the xps project and tied to either axi or axi-lite buses but didn't work. There exist unmapped addresses when I tied bridges to axi bus.
Could you share your final mhs file or explain how you integrated bridges to the system, via axi4 or axi4-lite? Thanks in advance..

Tuna
0 Kudos
Highlighted
Adventurer
Adventurer
4,755 Views
Registered: ‎03-16-2010

Re: AXI processor with TFT controller

Jump to solution

A collegue found that something went wrong with transactions from the TFT controller to the memory when using the PLB2AXI bridge so we ended up writing our own bridge; which instantly solved the issue.

 

I know this does not help people running into this but the core message is: the bridge is currently broken for use with the TFT controller...

0 Kudos