UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
501 Views
Registered: ‎02-17-2009

AXI4-Stream Infrastructure IPs' aclken polarity is showing wrong ?

Jump to solution

I believe the polarity of the aclken input for all of the infrastructure cores is active high. However, this is not really mentioned anywhere in PG085 (however it is mentioned in UG761) and it is wrongly shown as active low when cores are instantiated in a block diagram. Please clarify.

 

Thanks,

/Mikhail

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
443 Views
Registered: ‎10-04-2016

Re: AXI4-Stream Infrastructure IPs' aclken polarity is showing wrong ?

Jump to solution

Hi @mmatusov,

Yes, the aclken input for the AXI4-Stream Infrastructure cores is an active high signal.

 

It looks like IPI automatically inserts the a bubble on the aclken pin of the AXI4-Stream IP. This would typically indicate an active low signal and is an error. There are a couple of bugs open about this. We are targeting a fix in 2019.1.

 

Regards,

 

Deanna

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

3 Replies
Xilinx Employee
Xilinx Employee
444 Views
Registered: ‎10-04-2016

Re: AXI4-Stream Infrastructure IPs' aclken polarity is showing wrong ?

Jump to solution

Hi @mmatusov,

Yes, the aclken input for the AXI4-Stream Infrastructure cores is an active high signal.

 

It looks like IPI automatically inserts the a bubble on the aclken pin of the AXI4-Stream IP. This would typically indicate an active low signal and is an error. There are a couple of bugs open about this. We are targeting a fix in 2019.1.

 

Regards,

 

Deanna

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

Explorer
Explorer
433 Views
Registered: ‎02-17-2009

Re: AXI4-Stream Infrastructure IPs' aclken polarity is showing wrong ?

Jump to solution

Hi @demarco,

 

Just to be clear, it's not only a bubble, the POLARITY pin property is set to ACTIVE_LOW as well.

 

/Mikhail

0 Kudos
Xilinx Employee
Xilinx Employee
430 Views
Registered: ‎10-04-2016

Re: AXI4-Stream Infrastructure IPs' aclken polarity is showing wrong ?

Jump to solution

Hi @mmatusov,

I missed that aspect in my initial response. Yes, that has been identified as a key part of resolving the issue.  The POLARITY property should be ACTIVE_HIGH, not the ACTIVE_LOW you are observing.

 

Regards,

 

Deanna

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos