UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor zpeezer44
Visitor
380 Views
Registered: ‎01-02-2019

Attempting to Program Nexys Video SPI Flash With Microblaze C Code

I have been following this tutorial and have had no luck. I am uncertain about how to configure the QSPI IP, because the tutorial starts assuming that I have done that part successfully, so I am not even sure if this is the root of my problem. I have tried these two configurations of this IP, compiled them, and exported them to the SDK, and none of them solved the problem:

image.thumb.png.aa5e7ea3bf9ff3b3460e9836e9c8e8a7.png

image.thumb.png.781a8a6983e1226faebca4b787f66c91.png

I made sure JP4 is in the QSPI position. On step 3.1 in the tutorial, I can see that the FPGA is programmed successfully and I see the following output (since I chose not comment out the VERBOSE define as suggested in the tutorial):

image.png.676a6730ca2fa44de186fc2e75b1f029.png

While programming the flash on step 4 I notice that my FPGA code is erased from the board (leds I had assigned to outputs turn off). Is that supposed to happen?

At the end of the tutorial I get no "hello world" output on the terminal after resetting the board, though the FPGA does seem to program from the flash successfully, so that portion works, but I can't get the C-code to run from the flash.

Here is the sdk_console_output.txt so you can see the steps I took in the sdk to program the board.

Tags (4)
0 Kudos
1 Reply
Explorer
Explorer
305 Views
Registered: ‎07-18-2011

Re: Attempting to Program Nexys Video SPI Flash With Microblaze C Code

If you are using Vivado 2018.3, try using 2018.2.2.  It appears something is broken in QSPI flash programming in 2018.3.   I cannot get it to work for me, either, but it works fine in 2018.2.2.  

See my post here:  https://forums.xilinx.com/t5/Configuration/SPI-bootloader-broken-in-2018-3/td-p/928739

 

0 Kudos