UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
1,764 Views
Registered: ‎02-20-2017

Building Peta linux for Microblaze synthesized in zynq SoC- Digilent ZYBO Board

HI,

Sorry if I am initiating already discussed topic, unfortunately, I was not able to find a relevant topic yet. (I am using ZYBO board)

 

I synthesized a microblaze along with Zynq Ps and enabled the S_AXI_HP0 to give access to the DDR memory from microblaze. Given non conflicting addresses for DDR memory segments dedicated for microblaze and PS (attaching block design and address editor). The hardware synthesized without errors and critical warning. While I was trying to build petalinnux (petalinux-v2016.4-) , during the hardware description import and kernel configuration step,(command :petalinux-config --get-hw-description -p /opt/pkg/peta/ ) I can't detect the Microblaze processor, instead it is selecting PS7_cortex a9_0 processor architecture in the kernel configuration. (Attaching the screenshot). I understand that the BSP is automatically generated by petalinux-v2016.4 and no need to manually do that. So I am stuck here and cant build petalinux for my project.

 

 

PS:- I tried the same way, with Arty board, to verify, my petalinux installation is perfect. It is perfectly selecting microblaze and building the linux. Also I verified my hardware on the Zybo by running baremetal code on microblaze and its working fine.

 

Looking forward for an answer since, I am hurdling with this so many days. 

Block Design.png
Address Editor.png
kernel.png
0 Kudos
1 Reply
Observer dpizzitolo
Observer
295 Views
Registered: ‎08-11-2018

Re: Building Peta linux for Microblaze synthesized in zynq SoC- Digilent ZYBO Board

I'm seeing the same thing occur, I'm going to try to override that setting as I'm getting compile errors as well.

0 Kudos