UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
440 Views
Registered: ‎11-17-2014

FreeRTOS program works fine when started with Xilinx SDK 2017.2 but not with FSBL

Jump to solution

I've never used FreeRTOS on a Zynq before and I am making a simple FreeRTOS program that sends out data via UDP using lwip.

 

When I start the FreeRTOS program using Xilinx SDK 2017.2 using the TCF Launch on Hardware action, it runs fine and I see my data go out to a remote program on a PC and also get logged by Wireshark.

 

However when I go to burn a bin file with a FSBL, bitstream, and the FreeRTOS program, to my board I don't get the same result as above. The FreeRTOS program says it is running but, I do not see anything in my Wireshark capture or any Ethernet activity on the port in windows task manager.

 

I have my bif file configured as follows:

 

the_ROM_image:
{
    [bootloader]fsbl.elf
    design_1_wrapper.bit
    rtos_streamer.elf
}

The FSBL is just the standard one that you can have Xilinx SDK generate, and the FSBL starts fine.

 

Is there a reason why a FreeRTOS program would do this? Is there any additional settings or functions I need to call when the FreeRTOS program starts running?

0 Kudos
1 Solution

Accepted Solutions
Contributor
Contributor
416 Views
Registered: ‎11-17-2014

Re: FreeRTOS program works fine when started with Xilinx SDK 2017.2 but not with FSBL

Jump to solution

I figured it out. The FreeRTOS heap size needed to be increased.

View solution in original post

0 Kudos
1 Reply
Contributor
Contributor
417 Views
Registered: ‎11-17-2014

Re: FreeRTOS program works fine when started with Xilinx SDK 2017.2 but not with FSBL

Jump to solution

I figured it out. The FreeRTOS heap size needed to be increased.

View solution in original post

0 Kudos